[解決済み]WordPress3.4にアップグレードするとlocalhostでメールが送信できない

2012 年 6 月 22 日

ホーム フォーラム その他 [解決済み]WordPress3.4にアップグレードするとlocalhostでメールが送信できない

このトピックには7件の返信が含まれ、4人の参加者がいます。5 年、 5 ヶ月前 hidek0724 さんが最後の更新を行いました。

8件の投稿を表示中 - 1 - 8件目 (全8件中)
  • 投稿者
    投稿
  • #51619

    hidek0724
    参加者

    こんにちは、お忙しいところ恐れ入ります。

    メール設定→localhostにて送信ができなかったため、SMTPサーバを設定したいのですが、

    Lolipopから提供されているsmtp.lolipop.jpを入力しても送信できません。

    どのように設定したら送信ができますでしょうか。

    ご指導のほど宜しくお願い致します。

    動作に関するご質問の場合は必ずご記入ください。


    WordPress のバージョン:3.4

    Welcart のバージョン:Version 1.1.7

    ご利用のテーマ:

    症状を確認したブラウザ:Chrome

    サーバー(会社名、サービス名):Lolipop

    SSLの利用: 無し

    WordPress のパーマリンク設定:


    #64829

    ecoff
    参加者

    同様の問題が発生しております。

    どうやらバージョンアップ後に発生したようなので、なんらかのバグではないかと考えています。

    バージョン情報や動作環境などもhideki0724さんと同じです。

    大変困っております。お忙しいとは存じますが、どうぞご指導のほど宜しくお願いいたします。

    #64830

    nanbu
    参加者

    こんにちは。

    ロリポップは、WordPressを3.4にアップグレードすると、PHPセーフモードがオンになってしまうようです。

    ロリポップの管理画面を確認してください。もしオフのようでしたら、一旦オンにしもう一度オフにしてみて下さい。

    これは公式な対処法ではございません。サーバー会社にお問い合わせください。

    #64831

    hidek0724
    参加者

    nanbu様

    早急な対応ありがとうございます。

    ご指摘の通り、ロリポップ側のPHPの設定でPHPセーフモードオフをphp.iniに書き込む事で改善されました。的確な対応ありがとうございました!

    以下に手順を記載しておきます。(※下記手順は利用サーバがLolipopの場合です)

    1. ロリポップのページに行き、自分のドメインでログインします。

    2. 左側ツールバーの[Webツール]→[PHP設定]をクリックします。

    3. 該当するドメインを選択します。(サブドメイン含めドメインが複数ある場合)

    4. “safe_mode” を [OFF] に変更し、[php.ini を設定する]をクリックします。

    以上で設定は完了です。この状態ですと、Wordpress3.4 でも[メール設定]localhostでメールが送信できます。画像も参考にして下さい。

    [attachment=7274,121] [attachment=7274,122]

    #64832

    ecoff
    参加者

    nanbu様、hidek0724様、ありがとうございます!

    無事にメールを送信できるようになりました。

    画像での説明もあり、たいへん参考になりました。

    #64833

    mamekichi
    参加者

    関連する記事がありました。

    wp-incudes/class-phpmailer.phpのバグということです。

    http://ja.forums.wordpress.org/topic/10749

    http://core.trac.wordpress.org/attachment/ticket/20970/20970.patch

    #64834

    nanbu
    参加者

    セーフモードでメール送信に不具合が出るのはおかしいと思ってはいたんですが、本体のバグだったんですね。情報ありがとうございます、mamekichiさん。

    #64835

    hidek0724
    参加者

    mamekichiさん

    情報ありがとうございます。

    本体のバグだったんですね。リンクの記事通り指定ファイルを修正したところ、PHPセーフモードがONの状態でも送信できるようになりました。一応画像と手順をはっておきます。

    1. FTPソフトでWordpressがインストールされているディレクトリに接続

    2. wp-includes→class-phpmailer.phpを開く

    3. 763, 769行目末尾にある$paramsを削除し保存

    以上です。

    [attachment=7294,123]

8件の投稿を表示中 - 1 - 8件目 (全8件中)

このトピックに返信するにはログインが必要です。