[解決済み] SSL設定の不具合について

2010 年 7 月 1 日

ホーム フォーラム 使い方全般 [解決済み] SSL設定の不具合について

このトピックには2件の返信が含まれ、2人の参加者がいます。7 年、 2 ヶ月前 hide さんが最後の更新を行いました。

3件の投稿を表示中 - 1 - 3件目 (全3件中)
  • 投稿者
    投稿
  • #49838

    hide
    参加者

    こんにちわ、hideといいます。

    試行錯誤してみたのですが、うまくいかないので、質問させてください。

    ホームページ:http://xxx.com (SSL動作確認済み)

    ショップページ:http://xxx.com/shop

    ※顧客のURLの為、公開は控えさせてください。

    ブラウザ:IE7

    welcart:バージョン 0.4.4

    WordPress 2.9.2

    パーマリンク:/%category%/%postname%/

    /shopのディレクトリにwordpress設置し、システム設定で下記の通り設定しました。

    Use SSL:チェック

    WordPress のアドレス (SSL):https://xxx.com/shop

    ブログのアドレス (SSL):https://xxx.com/shop

    カートに商品を入れると、

    「このページにはセキュリティで保護されている項目と?」

    のメッセージが表示されます。

    「いいえ」を選択すると、正常にSSLマークが表示され、

    「はい」を選択すると、SSLマークは消えてしまいます。

    Firefoxで閲覧した場合は、上記のメッセージなしで、

    カートが表示され、SSLマークには警告マークがつき、

    安全性が確保されないと表示されます。

    リンクはいずれも

    https://xxx.com/shop/?page_id=3

    で表示されます。

    Firefoxの場合も、ページ内にhttpリンクの画像等が含まれていることが

    原因なのでしょうか?

    ここで質問するべき内容ではないかもしれませんが、

    ご解答いただけないでしょうか?

    よろしくお願いいたします。

    #59896

    nanbu
    参加者

    こんにちは。

    うまくSSLを通らないものが有る理由は主に2つあります。

    一つは、他のプラグインが直書きでスタイルシートやJavaScript を読み込んでいる。

    もう一つは、テーマのカスタマイズで画像などのリンクをテンプレートタグを使用せずに直に書いている。

    前述はhtml ソースを眺めて怪しいプラグインを外してみます。該当するものが有った場合それは使えないことになります。

    後述は、ご自分でカスタマイズされているのであれば簡単ですね。

    あと、できれば最新バージョンにアップグレードして下さい。

    #59897

    hide
    参加者

    nanbu 様

    ご回答ありがとうございます。

    原因はプラグインでした。

    「WP lightbox 2」を使用していたのですが、プラグインのphpの<?php echo $url; ?>が原因だったようです。

    wp-lightbox2.phpのリンクの書き換えで解決することができました。

    ライトボックスとSSLの相性問題は有名だったようですね。

    ありがとうございました。

3件の投稿を表示中 - 1 - 3件目 (全3件中)

このトピックに返信するにはログインが必要です。