[解決済み] WP3.0のカスタムナビメニューが効かない

2010 年 7 月 24 日

ホーム フォーラム テンプレート(テーマ) [解決済み] WP3.0のカスタムナビメニューが効かない

このトピックには4件の返信が含まれ、2人の参加者がいます。7 年、 4 ヶ月前 buru さんが最後の更新を行いました。

5件の投稿を表示中 - 1 - 5件目 (全5件中)
  • 投稿者
    投稿
  • #49881

    buru
    参加者

    こんばんは。

    WP3.0にはじめてwelcart0.52を入れてみました。

    ナビメニューをカスタマイズしようと管理画面のメニュー設定で希望項目だけメニューを選んで保存してみたものの、サイトには一向に反映される気配がありません。

    「twenty one」では問題なく設定通りのメニューがでるのですが、何故でしょうか?

    #60062

    nanbu
    参加者

    こんにちは。

    Welcart をアップグレードした場合、テーマは書き換えられません。

    v0.5.2 ではデフォルトテーマの修正も行われているのでテーマもアップグレードしてください。テーマのアップグレードの方法は次の通りです。

    【テーマをカスタマイズしていない場合】

    1.Welcart Dfault テーマを削除します。

    2.Welcart プラグインを停止し、再度有効化します。

    これで新しいヴァージョンのテーマがインストールされます。

    【テーマを削除したくない場合】

    Welcart プラグイン内の usc-e-shop/theme/welcart_default/functions.php をテーマフォルダ内のfunctions.php に上書きしてください。

    functions.php をカスタマイズしている場合は、内容を確認して必要なコードを追加してください。

    #60063

    buru
    参加者

    早々よりご回答感謝いたします。

    実は完全にアップグレードではなく、完全に新規インストールの状態での現象発生です。

    試行して状況がわかってきましたのでご報告します。

    (1)既存のテーマでカスタムナビを作っていた場合:Welcartにテーマを切り替えてもカスタムナビの設定内容が引き継がれない。

    (2)新の状態からカスタムナビを作る場合:Welcartで製作すれば問題なく表示される。この場合、Twentyoneにテーマを切り替えると、カスタムナビの設定が引き継がれるケースとそうでないケースがある。(←意味のないテストですが・・・・)

    ということですので、welcartというよりWPの問題だったようです。対応方法は問題が生じたらカスタムナビの設定を全部消して、設定しなおせば良い、ということになります。

    ・・・ということでナビ、作り直してます。(大汗)

    #60064

    nanbu
    参加者

    こんにちは。

    「テーマの場所」というのがポイントになります。

    テーマの場所とはテーマ毎に違っています。

    たまたま同じ設定だった場合はそのまま引き継がれることも有りますが、基本的にテーマを変えた場合はメニューの適用を確認したほうがいいです。

    メニュー自体は消えてしまうことは無いので「テーマの場所」の設定を確認するだけだと思います。

    #60065

    buru
    参加者

    おはようございます。 「テーマの場所」ですか。

    そういえば、WELCARTに限らず、消しても何故か設定値が残ってしまうなど他でも困った経験があります。

    今後は「場所」にも気をつかっていきたいと思います。

    サポート、どうもありがとうございました。

5件の投稿を表示中 - 1 - 5件目 (全5件中)

このトピックに返信するにはログインが必要です。