解決済管理画面を表示しようとしたらエラーになります

フォーラム 使い方全般 【解決済】管理画面を表示しようとしたらエラーになります

  • このトピックには4件の返信、2人の参加者があり、最後にmint1414により3週、 3日前に更新されました。
5件の投稿を表示中 - 1 - 5件目 (全5件中)
  • 投稿者
    投稿
  • #95126
    mint1414
    参加者

    WordPress のバージョン:5.4.7
    Welcart のバージョン:Welcart e-Commerce (バージョン 1.9.30)
    PHP のバージョン:7.2.30
    Welcart専用の拡張プラグインとバージョン:なし
    ご利用のテーマ:Welcart Beldad (バージョン 1.0.5)
    症状を確認したブラウザ:Chrome
    サーバー【重要】:AWS
    ===================================================================
    お世話になっております。
    本日より、管理画面にアクセスすると「サイトに重大なエラー」が表示され管理画面が開けなくなってしまいました。
    デバッグモードで内容を確認すると、下記のエラーが出ております。
    Uncaught Error: Cannot use object of type WP_Error as array in /var/www/html/wordpress/wp-content/plugins/usc-e-shop/includes/update_check.php:45

    こちらのトピックと同じエラーかと思いますが、どのように対応したらいいでしょうか。
    1.9.30にアップデートすると管理ページがエラーとなる
    https://www.welcart.com/community/forums/topic/1-9-30%E3%81%AB%E3%82%A2%E3%83%83%E3%83%97%E3%83%87%E3%83%BC%E3%83%88%E3%81%99%E3%82%8B%E3%81%A8%E7%AE%A1%E7%90%86%E3%83%9A%E3%83%BC%E3%82%B8%E3%81%8C%E3%82%A8%E3%83%A9%E3%83%BC%E3%81%A8%E3%81%AA

    #95127
    yskysmr
    キーマスター

    こんにちは。

    このエラーは古いバージョンの Welcart をお使いのときに発生するエラーです。
    今現在も、まだこのエラーが表示されている状態でしょうか。

    #95128
    mint1414
    参加者

    はい、今現在もエラーが出ております。
    該当箇所をスキップするようにしたらログイン画面が表示されたのですが根本的な解決ではないため、その状態でログインし、Welcartをバージョンアップしたらいいでしょうか。

    #95129
    yskysmr
    キーマスター

    mint1414 様

    はい、仰るとおりの対応をしていただきたく存じます。
    古いバージョンの WordPress、Welcart および他のプラグインには、脆弱性が含まれる場合もありますので、WordPress とプラグインは都度アップデートしてご利用くださいますよう、お願いいたします。

    #95134
    mint1414
    参加者

    ありがとうございます。
    アップデートいたします。

5件の投稿を表示中 - 1 - 5件目 (全5件中)
  • このトピックに返信するにはログインが必要です。