1.9.27にアップデートすると Chrome ver80 で Session Cookie が設定されない

ホーム フォーラム インストール 1.9.27にアップデートすると Chrome ver80 で Session Cookie が設定されない

このトピックには2件の返信が含まれ、2人の参加者がいます。6 ヶ月、 1 週前 mt さんが最後の更新を行いました。

3件の投稿を表示中 - 1 - 3件目 (全3件中)
  • 投稿者
    投稿
  • #89358

    mt
    参加者

    ——————————————-
    WordPress のバージョン:5.3.2
    Welcart のバージョン:1.9.27
    PHP のバージョン:7.2.27
    Welcart専用の拡張プラグインとバージョン:WCEX SKU Select 1.1.5
    ご利用のテーマ:WelcartBasic の自作子テーマ
    症状を確認したブラウザ:Google Chrome バージョン: 80.0.3987.132
    サーバー:XServer
    SSLの利用:SSLなし
    ——————————————–

    usceshop.class.php 内の
    session_set_cookie_params にて
    セッションクッキーパラメータsecure=false と SameSite=None の組み合わせが起きると Chrome に拒否されるのかもしれません。常時SSLの環境では問題は起きていません。
    ひとまず SameSite=None を外すことで問題を緊急回避しました。

    #89430

    yskysmr
    キーマスター

    こんにちは。

    別トピックでもご指摘いただいたとおり、v1.9.28 でも非SSL の環境でまだ問題があるようです。検証して修正いたしますので、しばらくお待ちください。ご不便をおかけしまして申し訳ございません。

    #89453

    mt
    参加者

    ご対応お待ちしております。
    よろしくお願いいたします。

3件の投稿を表示中 - 1 - 3件目 (全3件中)

このトピックに返信するにはログインが必要です。