1.0.5アップデート後、index.phpで商品一覧が表示されなくなりました。

2011 年 7 月 23 日

ホーム フォーラム インストール 1.0.5アップデート後、index.phpで商品一覧が表示されなくなりました。

このトピックには5件の返信が含まれ、3人の参加者がいます。6 年、 3 ヶ月前 tokinais さんが最後の更新を行いました。

6件の投稿を表示中 - 1 - 6件目 (全6件中)
  • 投稿者
    投稿
  • #50546

    foolishlife
    参加者

    はじめまして。

    Welcart、ありがたく使わせて頂いております。

    先ほど、Welcartを1.0.4から1.0.5にアップデートしたところ、index.phpに表示されていた商品一覧が表示されなくなりました。

    index.phpからはloop.phpというテンプレートを呼んでいて、loop.phpでループ処理をしています。

    同様の処理をしているカテゴリーページ(category.php + loop-category.php)やアーカイブページ(archive.php + loop-archive.php)は正常にリスト表示されます。

    テーマは「Shaken Grid Free」というものをカスタマイズして使用しています。

    可能性としてどのようなことが考えられるか、ヒントなど頂けますと幸いです。

    宜しくお願い致します。

    動作に関するご質問の場合は必ずご記入ください。


    Welcart のバージョン:1.0.5

    症状を確認したブラウザ:google chrome 12.0.742.122 , Safari 5.0.5 , Firefox 3.6.18 いずれもWindows

    サーバー(会社名、サービス名):さくらインターネット

    SSLの利用: 共用SSL

    WordPress のパーマリンク設定:/items/%postname%/


    #62440

    nanbu
    参加者

    こんにちは。

    ご報告ありがとうございます。

    とりあえず下記のファイルをこの様に修正していただきますと表示されると思います。応急処置としてお願いいたします。

    usc-e-shop/classes/usceshop.class.php 6591行目

    if( ($this->options['divide_item'] && !is_category() && !is_search() && !is_singular() && !is_admin()) || is_home() ){

     ↓

    if( $this->options['divide_item'] && !is_category() && !is_search() && !is_singular() && !is_admin() ){

    原因を調査しますのでしばらくお待ち下さい。

    なお、これはトップページの商品データの表示のみに関係するもので、その他の機能に影響はございません。

    よろしくお願いいたします。

    #62441

    foolishlife
    参加者

    nanbuさま

    早々にご回答頂き、ありがとうございます。

    無事、商品一覧が表示されました。

    応急処置とは言え、助かりました。。。

    今後とも、宜しくお願い致します。

    #62442

    tokinais
    参加者

    はじめまして。

    やはり、1.0.5アップデート後、商品画像が表示されなくなりました。上記の対応を行ってみたのですが、変化がありません。


    Welcart のバージョン:1.0.5

    症状を確認したブラウザ:Firefox 3.6.19 Safari バージョン 4.1.3(4533.19.4) いずれもmac

    サーバー(会社名、サービス名):xserver

    SSLの利用: 共用SSL

    WordPress のパーマリンク設定:

    URL : http://www.jiarex.com/


    よろしくお願い致します。

    #62443

    nanbu
    参加者

    こんにちは、tokinais さん。

    このトピックは「index.php での一覧表示」という括りがございますので状況が違うと思います。

    まずは、管理パネル「メディア」から、画像のメディアタイトルが間違いなく商品コードと一致しているかを確認してみてください。

    #62444

    tokinais
    参加者

    nanbu さん。

    トピックの件、大変失礼致しました。

    素人ながら、原因がアップデートのためだと思い、こちらでコメントさせて頂きました。すみません。

    また、ご指摘のところ確認し、修正したところ表示されました。

    ありがとうございます。

6件の投稿を表示中 - 1 - 6件目 (全6件中)

このトピックに返信するにはログインが必要です。