error :[object Object]が表示される。

ホーム フォーラム 使い方全般 error :[object Object]が表示される。

このトピックには6件の返信が含まれ、3人の参加者がいます。1 ヶ月前 k.ida さんが最後の更新を行いました。

7件の投稿を表示中 - 1 - 7件目 (全7件中)
  • 投稿者
    投稿
  • #85241

    k.ida
    参加者

    サポート担当者様

    お世話になります。
    Welcartをインストールした後にWordPressのダッシュボード>Welcart Shopへ遷移すると
    添付ファイルにあるように画面の右上にある表示モードの下にあるメッセージボックスに
    文章が表示されず、ERRORとなってしまいます。
    おそらく、これが原因と思われるのですが、ホームや商品マスタなどをクリックした際に
    画面が切り替わるまでが異常に遅くなります。
    原因について、ご教示いただきたく。
    以下に当方の環境を示します。

    WordPress 4.9.4
    Welcart 1.9.9.1802022
    Wekcart Basic 1.2.6
    Firefox 58.0.2(32bit)
    Chrome 64.0.3282.167(Official Build)32bit
    Welcart専用の拡張プラグインは、使用しておりません。
    サーバーは、社内にあります。

    以上

    Attachments:
    You must be logged in to view attached files.
    #85264

    yskysmr
    キーマスター

    こんにちは。

    サーバーは、社内にあります。

    とのことですが、ローカルサーバーで構築中ということでしょうか。
    ホーム画面のメッセージは、オンライン時に参照しますので、表示できていないだけです。管理画面の表示が遅い原因ではないと思います。

    #85265

    k.ida
    参加者

    キーマスター様

    お忙しいところ、ご回答いただきありがとうございます。
    まず、サーバーの件ですが、現在評価を行いためにローカルサーバー上に
    VM環境を構築し、そこにWordPressとWelCartを実装し、
    機能評価を行っております。
    ホーム画面のメッセージが、表示できない件と管理画面が遅い件を
    結びつけた理由について、説明不足がありましたので、補足させていただきます。
    まず、ダッシュボード>Welcart Shopへ移動した際に、
    最初の表示ページは、[ホーム]になると思いますが、
    [ホーム]から他のページ(例えば[商品マスタ])へ遷移する最初のタイミングでerror表示が発生し、時間がかかったのち、商品マスタのページに遷移します。
    いったん、[商品マスタ]のページに遷移してしまえば、他のページへの遷移には時間がかかりません。
    但し、この状態から再び[ホーム]に遷移すると、ここから他のページに遷移しようとする際に再びerror:[object Object]が表示され、時間がかかった後に遷移先のページが表示されます。
    こちらの想定では、[ホーム]が表示されるタイミングで常にメッセージ内容を取得しようとして、メッセージの取得ができないため、タイムアウト待ちとなっているのではないかと想定しております。
    そこで、ご相談なのですが、このメッセージ表示を抑止する方法は、ありませんでしょうか?
    また、メッセージ取得のために使用している通信方式およびポート番号をご教示いただけないでしょうか?
    フォーラムへのアクセスは行えているのでメッセージ取得の方法として、ブラウザで使用している通信方式やポート番号以外の方法で取得に取得に行っており、それが当社のセキュリティポリシーに抵触してる可能性を疑っております。

    以上

    #85431

    nanbu
    参加者

    こんにちは

    メッセージの取得は、jQuery.ajaxを使用して、弊社サーバーにアクセスしています。

    #85443

    k.ida
    参加者

    サポートご担当者様

    お忙しいところ、ご返信いただきましてありがとうございます。
    メッセージの取得は、jQuery.ajaxを使用しているとのこと、了解しました。
    その後、こちらで追加の調査を行うために、自宅に類似の環境を構築し、
    動作確認を行ったところ、正常にメッセージが表示されることを確認しました。
    このことから、おそらく社内のネットワーク(おそらくプロキシ)の影響を受けているものと
    推察されます。
    そこで、新たな質問ですが、情報の取得に使用している通信プロトコルをご教示いただけないでしょうか?(おそらく、httpもしくは、httpsだと思いますが・・・)

    以上

    #85459

    nanbu
    参加者

    usc-e-shop/functions/item_post.php ファイルの関数 usces_getinfo_ajax をご参照ください。

    #85464

    k.ida
    参加者

    お忙しいところ、ご回答ありがとうございます。
    具体的な処理を行っているソースの個所を開示していただけましたので、
    こちらで解析が行えそうです。
    また、最悪の場合でも、ソースを修正すれば、
    こちらのやりたいことはできそうです。
    根本的な原因究明は、これからですが、ご対応に感謝いたします。

7件の投稿を表示中 - 1 - 7件目 (全7件中)

このトピックに返信するにはログインが必要です。