PayPalエクスプレスチェックアウト支払い画面

2015 年 10 月 1 日

ホーム フォーラム 使い方全般 PayPalエクスプレスチェックアウト支払い画面

このトピックには4件の返信が含まれ、2人の参加者がいます。1 年、 9 ヶ月前 Hiroshi80 さんが最後の更新を行いました。

5件の投稿を表示中 - 1 - 5件目 (全5件中)
  • 投稿者
    投稿
  • #75898

    Hiroshi80
    参加者

    PayPalでの支払い画面に関しておうかがいできればと思います。
    現在PayPalエクスプレスチェックアウトを支払いに選択しているのですが、ショッピングカートへ商品を入れ購入手続きを進めていったところ、住所を入れるページで住所等を確定し、次のページへ行くとまた同じく住所を入れるページとプラスで配送方法を設定するページがでてきてしまいます。住所も前ページに入れた国名と違う国が表示されており修正しなければならない状態です。
    本来ならば最初のページで住所等は全て確定されているので次のページでは配送方法のみ設定するページになると思うのですが。
    修正点等ございましたらおうかがいできればと思いますので宜しくお願いいたします。
    下記動作環境となります。

    WordPress のバージョン:4.2.5
    Welcart のバージョン:1.4.21
    ご利用のテーマ:Espresso
    症状を確認したブラウザ:Internet explorer
    サーバー(会社名、サービス名):さくらインターネット
    SSLの利用: あり(ラビットSSL)
    WordPress のパーマリンク設定:数字ベース

    #75922

    yskysmr
    キーマスター

    Hiroshi80 様

    その状況は、「発送・支払設定」画面で、「配送先情報」の入力フィールドが、最初から展開されているようなイメージでしょうか。

    通常は、カートページ→お客様情報入力画面→発送・支払方法入力画面→内容確認画面となり、Hiroshi80様の仰る「住所を入れるページで住所等を確定し」とは、「お客様情報入力画面」のことでしょうか。こちらはあくまで”購入者の情報”でして、配送先を特定する情報ではございません。
    発送・支払方法入力画面に進みますと、「お客様情報と同じ」か「別の発送先を指定する」を選択できるようになっていて、「別の発送先を指定する」で初めて、配送先の情報を入力するフィールドを表示するようにしています。

    発送先の初期値は「お客様情報と同じ」になっていますので、最初から配送先の情報を入力するフィールドが表示されていることはございません。

    ご利用のテーマを「Welcart Default Theme」に変えて、実行してみてくださいますでしょうか。

    #75923

    Hiroshi80
    参加者

    ご連絡ありがとうございます。
    はい、おっしゃっていただいた通り「発送・支払設定」画面で、「配送先情報」の入力フィールドが、最初から展開されている状態です。
    「発送・支払設定」画面では再び住所等を入力することはないと思うのですが、既に入力済みの住所等の情報が再び展開された状態で出てきており、プラスで配送方法の指定欄が加わっている状態です。
    Welcart Default Themeに変えて同様の作業を行ってみたところ、発送・支払設定で住所等が再び展開されることはなく、配送方法の指定欄のみ表示され、その次の画面で全ての内容確認画面となり一番下にPayPalのボタンが表示される形でした。
    これが本来の形だと思うのですが、現在使用しているオリジナルのテーマではうまく機能していないようでした。
    どこを修正すればデフォルトのテーマのようにスムーズに決済を進めていくことができるのか、度々申し訳ありませんがおうかができればと思います。

    #75929

    yskysmr
    キーマスター

    Hiroshi80 様

    Welcart Default Theme では正常な動作をご確認いただけたということは、ご利用のテーマ内の何らかが影響しているのだとは思われます。ですが、お使いのテーマを知り得ない私共には、「どこを修正すれば」とは、申し上げられるものではございません。
    何卒ご了承くださいますよう、お願いいたします。

    #75932

    Hiroshi80
    参加者

    ご連絡ありがとうございます。
    大元のテーマが影響を与えているとのことで承知いたしました。
    その後テーマのfunctions.phpファイルを修正したところ通常通り機能するようになりました。
    この度は度々お手数おかけしました。
    ご丁寧にご回答いただき誠にありがとうございました。

5件の投稿を表示中 - 1 - 5件目 (全5件中)

このトピックに返信するにはログインが必要です。