php7.2以上でWarningが表示される

ホーム フォーラム バグ報告 php7.2以上でWarningが表示される

このトピックには2件の返信が含まれ、2人の参加者がいます。3 週間、 3 日前 ooshima さんが最後の更新を行いました。

3件の投稿を表示中 - 1 - 3件目 (全3件中)
  • 投稿者
    投稿
  • #89858

    ooshima
    参加者

    いつもお世話になっております。
    これまでphp5.6で使用していたのですが、php7.2(7.3、7.4も同様です)以上にバージョンを変更すると、カートページ内でWarningが表示されるようになってしまいました。

    Warning: count(): Parameter must be an array or an object that implements Countable in /home/●●/www/●●/wp-includes/post-template.php on line 317

    カートページの最初の画面にのみ発生する現象のようです。
    どのようにすればよいでしょうか? ご教授願えますと幸いです。

    ——————————————-
    WordPress のバージョン:WordPress 5.4.1
    Welcart のバージョン:1.9.30
    PHP のバージョン:7.2.29以上で確認
    Welcart専用の拡張プラグインとバージョン:WCEX DL Seller 3.0.10
    ご利用のテーマ:WelcartBasic の自作子テーマ
    症状を確認したブラウザ:クロム
    サーバー:さくらサーバー スタンダードプラン
    SSLの利用:SSL可している
    ——————————————–

    Attachments:
    You must be logged in to view attached files.
    #89875

    nanbu
    参加者

    こんにちは

    下記のテンプレートをご覧ください。
    wc_templates/cart/wc_cart_page.php

    このテンプレートの下記の記述を削除していただくと良いかと思います。

    <?php the_content();?>

    どうぞよろしくお願いいたします。

    • この返信は3 週間、 3 日前に  yskysmr さんが編集しました。
    #89879

    ooshima
    参加者

    nanbu様

    いつもありがとうございます。
    解決いたしました!

3件の投稿を表示中 - 1 - 3件目 (全3件中)

このトピックに返信するにはログインが必要です。