SSL使用時に画像が表示されない

2015 年 12 月 9 日

ホーム フォーラム その他 SSL使用時に画像が表示されない

このトピックには11件の返信が含まれ、3人の参加者がいます。2 年前 yskysmr さんが最後の更新を行いました。

12件の投稿を表示中 - 1 - 12件目 (全12件中)
  • 投稿者
    投稿
  • #76576

    uishi
    参加者

    ——————————————-
    WordPress のバージョン:4.4
    Welcart のバージョン:1.6.3
    ご利用のテーマ:デフォルトの子テーマ
    症状を確認したブラウザ:firefox クローム
    サーバー(会社名、サービス名):ヘテムル
    SSLの利用: あり
    WordPress のパーマリンク設定:デフォルト
    ——————————————–
    自作のスライドウィジエット等
    カートページの画像
    がwelcartのシステムのSSLを使用だと
    srcsetのURLがhttps:になって表示されないようですが、
    同様の症状の方はいらっしゃいますでしょうか。

    #76579

    yskysmr
    キーマスター

    uishi 様

    ご報告ありがとうございます。
    ただ、弊社で検証しましても画像が表示されないということがありませんでしたので、質問させていただいてよろしいでしょうか。

    ・HTTPS プラグインをご利用でしょうか。

    ・Welcart Shop>システム設定>「SSL を使用する」にチェックをされていますでしょうか。

    ・サイト全体を SSL にされていますでしょうか。

    Welcart では WordPress 4.4 対応として、srcset の対応を行いました(v1.6.3で完了しています)。念のため、対応箇所を再度修正しましたので、大変お手数ですが Development Version にアップデートして、ご確認いただけますでしょうか。

    よろしくお願いいたします。

    #76593

    uishi
    参加者

    yskysmr様

    httpsプラグインはインストールした覚えがありません。
    SSLを使用するとファイル名が表示されて画像は表示されません。
    サイト全体にSSLは設定していないと思います。
    カートページ等のみ

    取り急ぎご報告まで。

    #76609

    yskysmr
    キーマスター

    uishi 様

    回答いただきありがとうございました。
    Welcart v1.6.3 にて、「SSL を使用する」にしているとき、srcset(が展開される場合)の URL を https:// にするという修正を行いました。この状態で画像が表示されないということは、まだ他にも原因があるのかもしれません。uishi 様のサイトを見せていただくことは可能でしょうか。よろしければ、レスキューナビのページより、サイトの URL をご連絡いただけますでしょうか。
    よろしくお願いいたします。

    #76610

    uishi
    参加者

    yskysmr様
    こちらの表現がおかしかったかのもしれませんが、
    SSLを使用時に、srcset内はhttpsと表示されています。
    結果おそらく画像がない扱いなのでaltが表示されている。
    ブラウザ付属の開発ツールで該当部分をhttpにすると表示される。
    ということです。
    仮に開発様の意図が「SSL使用時にはsrcset内のURLはすべてhttps」にするなら
    意図どおりの挙動だと思います。
    がそれだと画像が表示されないということです。

    #76611

    uishi
    参加者

    カートページで画像が表示されない原因は、
    SSL使用時のURL
    WordPress のアドレス (SSL)ヘテムル指定の共用SSL/サイトドメイン
    ブログのアドレス (SSL)弊社の場合うえとおなじ
    がsrcset内のURLには加えられていないからかもしれません。
    https://サイトURL
    ではなく
    https://WordPress のアドレス (SSL)であるべきなのかもしれません。
    追加したら表示しました。

    それとトップページや商品詳細のページは、SSLを設定していないので、
    httpのままであって欲しいんですが。

    • この返信は2 年前に  uishi さんが編集しました。
    #76613

    uishi
    参加者

    yskysmr様
    いまDevelopment Versionの該当ファイルのみ入れ替えました。
    全部入れ替えは怖かったもので今までしていませんでした、ご連絡が遅れてすいません。
    トップページや商品詳細ページで画像が表示されるようになりました。
    カートページについてはaltが表示されたままです。

    #76615

    yskysmr
    キーマスター

    uishi 様

    回答いただきありがとうございました。
    共有SSL を使用時の対応が抜けておりました。今ほど、再度 Development Version にて修正いたしましたので、大変お手数ですが、Development Version にアップデートしてご確認いただけますでしょうか。

    よろしくお願いいたします。

    #76617

    uishi
    参加者

    yskysmr様
    共有SSLを使用時の対応版のファイルを入れ替えたら、
    カートページも商品のサムネイルを表示するようになりました。
    お忙しいなか、お時間を割いていただきありがとうございました。

    #76619

    yskysmr
    キーマスター

    uishi 様

    ご確認いただきまして、ありがとうございました。

    #76632

    grace
    参加者

    お疲れ様でございます。
    バージョン:1.6.4 でまたカートページの画像が表示されていないようです。
    ご確認よろしくお願いいたします。

    #76633

    yskysmr
    キーマスター

    grace 様

    ご報告ありがとうございました。Development Version にて修正いたしましたので、大変お手数ですが、Development Version にアップデートしてご確認いただけますでしょうか。
    ご不便をおかけしまして、申し訳ございません。どうぞよろしくお願いいたします。

12件の投稿を表示中 - 1 - 12件目 (全12件中)

このトピックに返信するにはログインが必要です。