解決済WCEX Amazon Pay利用時のエラー

フォーラム 拡張プラグイン 【解決済】WCEX Amazon Pay利用時のエラー

  • このトピックには7件の返信、2人の参加者があり、最後にkota2により2ヶ月、 3週前に更新されました。
8件の投稿を表示中 - 1 - 8件目 (全8件中)
  • 投稿者
    投稿
  • #96176
    kota2
    参加者

    ——————————————-
    WordPress のバージョン:5.9.1
    Welcart のバージョン:2.5.4
    PHP のバージョン:7.3.15
    Welcart専用の拡張プラグインとバージョン:WCEX Amazon Pay 2.4.1
    ご利用のテーマ:Welcart Beldad、Welcart Basic 両方で確認
    症状を確認したブラウザ:Google Chrome バージョン: 87.0.4280.88
    サーバー:さくらのレンタルサーバ マネージドプラン
    SSLの利用:常時SSL
    ——————————————–

    お世話になります。

    WCEX Amazon Payの導入・設定を行い、
    実際に購入時にAmazonPayボタンをクリックしたところ、下記エラーURLへ飛んでしまいます。
    https://payments.amazon.co.jp/checkout/initiate
    「問題が発生しました。販売事業者のサイトに戻ってもう一度お試しいただくか、販売事業者にお問い合わせください。
     Error Code: InvalidRequest」

    のエラーが表示され、先に進めない状況です。
    干渉するであろうプラグインは全て停止してみましたが状況は改善されず、
    試しにWelcartBasicに切り替えてみたところ、上記URLへは飛びませんでしたが、
    決済画面のまま「ご不明なエラーが発生しました」と表示され、先に進めませんでした。

    AmazonPayの各種ID・キー・秘密鍵は間違っておらず、テスト環境・本番環境どちらでも同じ事象でした。

    お手数おかけしますが、対処方法をご教示いただけますでしょうか。
    どうぞよろしくお願いいたします。

    #96177
    kota2
    参加者

    画像が容量オーバーだったため、再度添付いたします。

    Attachments:
    You must be logged in to view attached files.
    #96180
    sagawa
    キーマスター

    kota2様

    こんにちは。
    テーマのバージョンを教えていただけますか?
    また、他のブラウザでも同じでしょうか?

    #96181
    kota2
    参加者

    早速のご返信ありがとうございます。

    テーマバージョンは以下でございます。
    Welcart Beldadバージョン: 1.0.2
    Welcart Basicバージョン: 1.4.3

    ブラウザは下記でも同じ事象が発生しております。
    Microsoft Edge バージョン 98.0.1108.56
    Safari バージョン15.2

    どうぞよろしくお願いいたします。

    #96188
    sagawa
    キーマスター

    こんにちは。

    Welcart Basicバージョン: 1.4.3およびWelcart Beldadバージョン: 1.0.2で行いましたが、再現はしませんでした。
    Basic認証などは設定されていないでしょうか?

    #96189
    kota2
    参加者

    ご確認ありがとうございます。
    アクセス制限・Basic認証はかけていない一般公開サイトです。

    先程同じサーバー上にて、
    同一テーマ・同一プラグインで新規サイトを立ち上げたらエラーは出ませんでした。
    何かデータに問題があるのかもしれないので、
    作り替えかWelcartレスキューの調査を検討させていただこうと思います。

    お手数おかけしました。

    #96196
    sagawa
    キーマスター

    kota2様

    ご連絡ありがとうございます。
    URLの最後の「/」が関係していることが分かりました。
    どうやら入っている場合にこちらのエラーが表示されるようです。
    何か設定等でURLの最後の「/」を制御しておられますでしょうか?

    #96197
    kota2
    参加者

    ご連絡ありがとうございます。

    URLが関係しているとのことでhtaccessを確認してみたところ、
    削除したプラグイン:SAKURA RS WP SSLによるリダイレクトの記述が残っており、
    それらを削除した結果、エラーが表示されなくなりました。

    迅速なご対応ありがとうございます。大変助かりました。

8件の投稿を表示中 - 1 - 8件目 (全8件中)
  • このトピックに返信するにはログインが必要です。