WCEX SKU Selectを利用した商品のカートボタンが表示されない

2017 年 5 月 16 日

ホーム フォーラム 拡張プラグイン WCEX SKU Selectを利用した商品のカートボタンが表示されない

このトピックには5件の返信が含まれ、3人の参加者がいます。3 ヶ月、 2 週間前 sebastian さんが最後の更新を行いました。

6件の投稿を表示中 - 1 - 6件目 (全6件中)
  • 投稿者
    投稿
  • #82957

    WCEX SKU Selectと独自SSLを利用しています。

    WPのアドレスとサイトアドレスを別々のURLに変更すると
    SUKセレクトを利用した商品のカートボタンが表示されなくなります。
    また、ブラウザによって表示されたり、されなかったりと異なります。

    ソースを確認すると、
    在庫はあるのに、在庫はある場合のスタイルが適用されていないようです。

    ひとまず、CSSを修正して強制的に表示しているのですが、
    影響しているのがCSSだけのものなのか、在庫判定まで影響しているのかわかりません。

    ・WPのアドレスとサイトアドレスを同一URLに戻すと治ります
    ・独自でJSを追加していますが、外しても同じ症状でした

    原因はわかりますでしょうか?

    【症状】

    以下の箇所で

    となるべきところが

    となるべきところが

    になっています。

    【こちらで行ったこと】
    ーー
    .htaccess,index.phpなどの変更をし、
    カート側の設定
    サイトのアドレス (SSL) を「https://xxxx.jp/wp」→「https://xxxx.jp」に変更

    WP自体の設定
    サイトのアドレスを「https://xxxx.jp/wp」→「https://xxxx.jp」に変更

    パーマリンク設定
    カスタム構造 https://xxxx.jp/%postname%.html
    ーー

    ——————————————-
    WordPress のバージョン:4.7.4
    Welcart のバージョン:1.9.2
    Welcart専用の拡張プラグイン:WCEX SKU Select,WCEX Multi Price
    ご利用のテーマ:Welcart Basic Childの自作子テーマ)
    症状を確認したブラウザ:Mac:Firefox:表示NG Safari:表示OK
    サーバー:お名前.com
    SSLの利用:常時SSL
    WordPress のパーマリンク設定:https://xxxx.jp/%postname%.html
    ——————————————–

    #82958

    タグがエスケープされてしまったようなので、画像で添付致します。

    Attachments:
    You must be logged in to view attached files.
    #82967

    yasumax
    キーマスター

    こんにちは。

    カート側の設定
    サイトのアドレス (SSL) を「https://xxxx.jp/wp」→「https://xxxx.jp」に変更

    管理画面[Welcart Shop]>[システム設定]にて「SSLを使用する」にチェックが入っていた場合、外してみてください。

    #83096

    sebastian
    参加者

    私も同様の症状が出ています。
    GoogleChrome58.0.3029.110 (64-bit)
    Safari(iOS10.3.2)
    現在この2つで確認しました。
    スレッドにある改善方法を試しましたが解決していません。
    一時的でも構わないので解決方法がありましたらお願いします。
    (CSSのカスタマイズなど)

    wordpress 4.7.5
    WCEX SKU Select 1.0.5

    #83099

    yasumax
    キーマスター

    > sebastian
    こんにちは。
    テーマは何を利用されていますでしょうか。

    場合によっては、テーマの修正の必要がありますので下記ドキュメントを参照してください。
    【参考URL】
    WCEX SKU Select ドキュメント
    テーマのカスタマイズ

    #83100

    sebastian
    参加者

    トピ主さんと同じくWelcart Basic Childの自作子テーマを利用しています。
    カスタマイズ済みで、これまでは普通に動いていたのですが(iOSのSafariでは動作確認出来ていました)、お客様の指摘で最近ボタンが消えていることに気がつきました。
    もう一度ファイルに記述を確認してみます。

6件の投稿を表示中 - 1 - 6件目 (全6件中)

このトピックに返信するにはログインが必要です。