welcartの「タグ設定」について

2014 年 12 月 28 日

ホーム フォーラム 使い方全般 welcartの「タグ設定」について

このトピックには6件の返信が含まれ、2人の参加者がいます。2 年、 8 ヶ月前 ecoken さんが最後の更新を行いました。

7件の投稿を表示中 - 1 - 7件目 (全7件中)
  • 投稿者
    投稿
  • #73175

    ecoken
    参加者

    お世話になります。

    商品登録の際に「タグ」が設定できると思いますが
    設定タグ
    例)プラチナ,ネックレス,レディースアクセサリー
    この3つの言葉を商品に設定し、
    商品詳細ページにて

    [関連ワード:プラチナ ネックレス レディースアクセサリー]

    このような感じで表示し、各ワードに同じタグを設定した商品一覧(アーカイブ)のリンクを付けたのですが

    <div>[関連ワード:<?php the_tags(‘

    • ‘,’
    • ‘,’

    ‘); ?>]</div>
    この書き方では同じタグを設定しているにも関わらず検索結果に
    ヒットするタグもあったり、ヒットしないタグもあったり
    何か設定、もしくはタグの使い方が誤っているのでしょうか?

    ご教授をお願いします。

    ——————————————-
    WordPress のバージョン:WordPress 3.9.3
    Welcart のバージョン:Version 1.4.12.1412031
    ご利用のテーマ:Welcart Default Theme テーマバージョン: 1.2
    症状を確認したブラウザ:Chrome
    サーバー(会社名、サービス名):ネットオウル ミニバード
    SSLの利用:固定IP独自SSL利用
    WordPress のパーマリンク設定:/%post_id%.html
    ——————————————–

    #73176

    ecoken
    参加者

    失礼しました
    html部分がきちんと表示されませんでした。

    <div>関連ワード:<?php the_tags(’<ul><li>’,’</li><li>’,’</li></ul>’); ?></div>

    半角から全角に変更しています。

    • この返信は2 年、 8 ヶ月前に  ecoken さんが編集しました。
    #73195

    nanbu
    参加者

    こんにちは。

    the_tags() をどのテンプレートに書いているのかが問題となります。商品詳細ページのテンプレート(wc_item_single.php)や投稿記事のテンプレート(single.php)でしたら正常に表示されるのではないでしょうか。

    #73206

    ecoken
    参加者

    nanbu様
    ご返信ありがとうございます。

    使用ファイルは
    wc_item_single.phpにて記入しております。
    <div>関連ワード:<?php the_tags(’<ul><li>’,’</li><li>’,’</li></ul>’); ?></div>
    [関連ワード:プラチナ ネックレス レディースアクセサリー]
    表示は問題なく表示しますが
    表示しているテキストリンクをクリックしたところ
    同じタグを設定している商品が「タグ別アーカイブ:」一覧で
    表示されると思うのですが
    同じタグを設定している商品が表示されません。

    ほとんどのタグが
    見つかりません
    リクエストされたアーカイブには何も見つかりませんでした。検索すれば関連投稿が見つかるかもしれません。

    の表示になります。

    何種類かのタグは
    同タグを設定した商品の「一部」(2~4商品)が表示されます。

    タグの設定はCSV一括、または管理画面より個別に設定しましたが
    どちらも変わりありません。
    データーベースの文字コード等の問題でしょうか?

    サーバのバージョン: 5.0.95
    プロトコルバージョン: 10
    サーバ: *****.******.netowl.jp via TCP/IP
    ユーザ: **********@*****.*****.netowl.jp
    MySQL の文字セット: UTF-8 Unicode (utf8)
    MySQL の接続照合順序: utf8_unicode_ci

    #73223

    ecoken
    参加者

    追記です

    全く意味が分らないのですがブラウザによって実行結果が違いました。
    例)関連ワード:ネックレスをクリック

    症状を確認したブラウザ:IE11,FF34
    こちらの2つのブラウザは
    見つかりません
    リクエストされたアーカイブには何も見つかりませんでした。検索すれば関連投稿が見つかるかもしれません。
    症状を確認したブラウザ:chorome 35.0
    このブラウザだと
    タグ設定した商品の一部が表示されました。

    何か不備があると思いますが
    サーバー側なのか?
    wordpressなのか?
    welcartなのか?

    無知で申し訳ありませんがご報告いたします。

    #73236

    nanbu
    参加者

    こんにちは。

    試に、「Welcart Shop -システム設定-」にて、「ループ表示の際、商品を分離して表示する」のチェックを外してみて確認していただけますか?

    #73248

    ecoken
    参加者

    nanbu様
    ご返信ありがとうございます。

    ループ表示の際、商品を分離して表示する
    のチェックは外れておりました。

    原因は完全に特定できていませんが
    全て新規インストールをしましたところ
    解決いたしました。
    恐らくデーターベースのエラー?破損?だと思います。

    <div class="tags">関連ワード:<?php the_tags('<ul><li>','</li><li>','</li></ul>'); ?></div>

    こちらのタグにて正常表示できております。

    ご回答いただきまことにありがとうございました。

7件の投稿を表示中 - 1 - 7件目 (全7件中)

このトピックに返信するにはログインが必要です。