welcartのページ属性

フォーラム 使い方全般 welcartのページ属性

  • このトピックには7件の返信、2人の参加者があり、最後にkitagawaにより1年、 4ヶ月前に更新されました。
8件の投稿を表示中 - 1 - 8件目 (全8件中)
  • 投稿者
    投稿
  • #99526
    shelter
    参加者

    welcartプラグインを導入したのですが、商品ページでページ属性テンプレートが選択できなくて困っています。

    プルダウン自体が表示されていない状態です(最初からの仕様だと思いますが)。

    おそらく商品ページ自体は投稿ページ扱いになっているようで、single-post.phpが反映しているようです。

    商品ページ用のテンプレートにしたいのですが、何か良い方法はないでしょうか?

    よろしくお願いいたします。

    • このトピックはkitagawaが1年、 4ヶ月前に変更しました。
    • このトピックはkitagawaが1年、 4ヶ月前に変更しました。
    #99531
    kitagawa
    キーマスター

    shelter 様

    こんにちは。
    大変恐れ入りますが、動作の検証には環境情報が必要です。
    投稿の際は下記の情報をお書き添えください。
    ——————————————-
    WordPress のバージョン:(例 6.0.2)
    Welcart のバージョン:(例 2.8.1)
    PHP のバージョン:(例 8.0)
    Welcart専用の拡張プラグインとバージョン:(例 DL Seller 3.4.1、SKU Select 1.4.2)
    ご利用の親テーマとバージョン :(例 Welcart Basic 1.7.1)
    ご利用の子テーマとバージョン :(例 Welcart Beldad 1.4)
    症状を確認したブラウザ:
    サーバー【重要】:(会社名、サービス名)
    ——————————————–

    ご協力のほどお願いいたします。

    また、内容に合わせてフォーラムのタイプを変更させていただきましたのでご了承ください。
    よろしくお願いいたします。

    • この返信は1年、 4ヶ月前にkitagawaが編集しました。
    #99541
    shelter
    参加者

    ご返答ありがとうございます。

    環境情報は下記の通りです。

    ——————————————-
    WordPress のバージョン: 6.1.1
    Welcart のバージョン: 2.8.13
    PHP のバージョン: 8.1
    Welcart専用の拡張プラグインとバージョン:なし
    ご利用の親テーマとバージョン : yuuta 1.6.3
    ご利用の子テーマとバージョン : yuuta-child 1.6.3
    症状を確認したブラウザ:chrome
    サーバー【重要】:ロリポップ
    ——————————————–

    よろしくお願いいたします。

    #99552
    kitagawa
    キーマスター

    shelter 様

    ご連絡ありがとうございます。

    環境情報を拝見した所PHPのバージョンが「8.1」となっております。
    本日時点でWelcartの推奨環境はPHP 7.4から8.0でございます。
    参考ページ: システム要件
    PHPのバージョンを 8.0 にダウングレードしてお試しいただけますか?

    また、ブロックエディタをご利用されていますか?

    お手数ですがご確認よろしくお願いいたします。

    #99557
    shelter
    参加者

    ご返答ありがとうございます。

    PHP変更は試してみますが、ダウングレードすると何かリスクがありますかね?

    たぶんブロックエディタだと思います。

    よろしくお願いします。

    #99563
    kitagawa
    キーマスター

    shelter 様

    ご返信ありがとうございます。

    > PHP変更は試してみますが、ダウングレードすると何かリスクがありますかね?
    PHP8.0はPHP公式サポート期限内ですので問題ございません。
    また、Welcart は PHP 8.0 → 8.1 の順で対応していきます。
    どのバージョンで対応されたかはこちらのリリース情報でご確認いただけますようお願いいたします。

    > たぶんブロックエディタだと思います。
    申し訳ございません。
    本日時点で Welcart の商品ブロック(名称未定)はまだご利用いただけません。
    今後対応する予定でございます。

    よろしくお願いいたします。

    #99567
    shelter
    参加者

    PHP8.0にダウングレードしました。
    しかしながら、ページ属性テンプレートの選択は表示されませんでした。

    通常は表示されるものでしょうか?
    何か他に方法はないでしょうか?

    よろしくお願いいたします。

    #99583
    kitagawa
    キーマスター

    shelter 様

    ご確認いただきありがとうございます。
    申し訳ありませんが、商品ページは「ページ属性テンプレート」には対応しておりません。

    商品ページを作成したい場合は有効化しているテーマ配下に wc_templates/wc_item_single.php を設置して下さい。
    [参考]
    Welcart1.7以降のテンプレート仕様について

    よろしくお願いいたします。

8件の投稿を表示中 - 1 - 8件目 (全8件中)
  • このトピックに返信するにはログインが必要です。