Welcart 1.8への更新でFatal Errorが出現してWPログインできません

2016 年 4 月 11 日

ホーム フォーラム インストール Welcart 1.8への更新でFatal Errorが出現してWPログインできません

このトピックには9件の返信が含まれ、3人の参加者がいます。1 年、 1 ヶ月前 MasanoK さんが最後の更新を行いました。

10件の投稿を表示中 - 1 - 10件目 (全10件中)
  • 投稿者
    投稿
  • #78096

    MasanoK
    Participant

    ——————————————-
    WordPress のバージョン:4.4.2
    Welcart のバージョン:1.8
    ご利用のテーマ:Welthemes
    症状を確認したブラウザ:Chrome
    サーバー(会社名、サービス名):Xserver
    SSLの利用:独自SSL利用中
    WordPress のパーマリンク設定:/%postname%
    ——————————————–

    いつもお世話になります。

    本日、WP起動後、更新1件の表示があり、Welcart1.8の更新でしたのですぐに実行いたしました。しかし、更新後、WPに再ログインしたところ、下記のエラーメッセージが表示され、ページが表示されなくなってしまいました。

    Fatal error: ‘continue’ not in the ‘loop’ or ‘switch’ context in /home/masano-k/masano-k.com/public_html/wp-content/plugins/usc-e-shop/extensions/OrderStockLinkage/order_stock_linkage.php on line 444

    Welcart, WPともに十分な知識を備えておりませんため、どのような対処が必要なのかまったくわからず困っております。
    これまで2年近く、1年半ほど、このような表示が表れたことはございませんでした。

    どうか、ご教示いただきたく、よろしくお願い致します。

    #78097

    nanbu
    Participant

    こんにちは

    恐れ入ります。PHPのバージョンを教えていただけますか?

    #78100

    nanbu
    Participant

    修正版Welcart1.8.1 をリリースしました。
    管理画面が表示されないとのことですので、FTPでのアップグレードが必要ですが、無理なようでしたら、レスキューの方へお問い合わせください。弊社の方で対応させていただきます。

    #78105

    MasanoK
    Participant

    お世話になります。

    PHPは:  PHP7.0.3

    となっております。

    よろしくお願い致します。

    #78106

    MasanoK
    Participant

    nanbuさま

    レスキューナビにご連絡申し上げればよろしいのでしょうか?

    いま、手も足もでなくて、困っております。

    #78107

    MasanoK
    Participant

    たびたびすみません。

    レスキューナビにお願いすると、12000円も費用がかかると理解します。
    費用をかけずに何とか復旧させる方法を、素人にもわかるようにご教示いただけるとありがたいのですが・・・

    よろしくお願い致します。

    #78109

    hidetatsu
    Participant

    横からすみません。

    PHPのバージョンがPHP7.0.3と仰っておりますが、welcertはPHP7.0の対応はまだのようです。

    Welcart ドキュメンテーション

    この辺が原因ではないでしょうか?

    #78110

    nanbu
    Participant

    Welcartは、PHP7に対応しておりません。

    Welcart ドキュメンテーション

    PHP5.6にダウングレードしていただけると表示するようになるかと思います。

    #78120

    MasanoK
    Participant

    hidetatsu さま、 nanbu さま、

    レスありがとうございます。

    ダウングレードを試してみてご報告致します。

    #78139

    MasanoK
    Participant

    nanbuさま、hidetatsuさま

    phpのバージョンを 7.0.3 から  5.5.3 に戻し、
    Welcart 1.8 搭載状態でうまく機能するようになりました。

    ショートカットから自サイトに入ろうとして、
    いきなり真っ白な画面にFatal Errorという文字を見つけ、
    かなりパニックしておりました(~_~;)

    私はXサーバーを利用していますが、
    自動的にPHPがアップグレードされているようで。。。

    本当にお騒がせして申し訳ありませんでした。

    今後とも、これに懲りずによろしくお願い致します。

10件の投稿を表示中 - 1 - 10件目 (全10件中)

このトピックに返信するにはログインが必要です。