Welcart Basicとカテゴリー

2016 年 1 月 21 日

ホーム フォーラム 使い方全般 Welcart Basicとカテゴリー

このトピックには6件の返信が含まれ、3人の参加者がいます。1 年、 1 ヶ月前 mamekichi さんが最後の更新を行いました。

7件の投稿を表示中 - 1 - 7件目 (全7件中)
  • 投稿者
    投稿
  • #77010

    mamekichi
    Participant

    ——————————————-
    WordPress のバージョン:4.4.1
    Welcart のバージョン:1.6.6.1512212
    ご利用のテーマ:デフォルトをカスタマイズ
    症状を確認したブラウザ:
    サーバー(会社名、サービス名):coreserver
    SSLの利用:あり 
    WordPress のパーマリンク設定:デフォルト
    ——————————————–
    お世話になります。
    現在は、Welcat defaultに色々手を加えたテーマを使用していて、問題はありません。

    先日、Welcart Basicをダウンロードしてテストをしております。

    トップページの画像の下にカテゴリを表示する部分がありますが、

    「該当する投稿は見つかりませんでした。」

    という表示され、商品が表示されません。

    この部分は、テーマのカスタマイズで、テーマオプションを選ぶと表示される「トップページ 商品リストカテゴリー」というプルダウンメニューでカテゴリーを選べば、それに応じた表示がされるものと思います。

    プルダウンメニューには、お勧め商品、商品ジャンルやその他の登録済みカテゴリが表示されています。

    しかし、どれを選んでもトップページに商品は表示されません。

    以上は、運用中のサイトで、 Welcart Basicテーマのライブヴューを選んで一時的に表示させたものです。

    動作確認用の別のサイトにテーマをインストールしてみましたが、症状は変わりませんでした。最後の手段と思い、データベースを作成し直して、再度インストールした結果、今度は表示できるようになりました。

    運用中のサイトのカテゴリに問題があると思います。カテゴリ関連のプラグインを停止しても結果は同じです。なお、運用中のテーマではカテゴリによる検索は正常に機能しています。

    カテゴリを「商品」「商品ジャンル」などのデフォルトのカテゴリを一旦消して、Welcartを停止させ、再度有効化 という手があるかと思いますが、影響が大きく最後の手段にしたいです。

    なにか他に良い方法はないでしょうか?

    #77014

    mamekichi
    Participant

    書き忘れていたので補足です。
    ウィジェトエリアに「Welcartカテゴリー」や「Welcartお勧め商品」を追加した場合、それらは正常に表示されます。

    #77018

    kitamuuu
    Participant

    こんにちは。

    以下の自分の環境ではライブビューでも問題なく表示されます。
    商品編集画面にて「お勧め商品」などのカテゴリは指定していますよね?
    エラーなどは何もでていませんか?
    可能であれば動作確認用の環境にてデバッグモードをtrueにして確認してみてください。

    テストしたバージョン
    WordPress :4.4.1
    Welcart :1.6.6
    Welcart Basicテーマ : 1.0.0

    • この返信は1 年、 2 ヶ月前に  welcart さんが編集しました。
    #77022

    mamekichi
    Participant

    kitamuuu 様
    ありがとうございます。

    >商品編集画面にて「お勧め商品」などのカテゴリは指定していますよね?
    指定しております。ウィジェット「Welcartカテゴリー」や「Welcartお勧め商品」に関しては正常に検索結果が表示されます。

    >エラーなどは何もでていませんか?
    何もでていません。

    >可能であれば動作確認用の環境にてデバッグモードをtrueにして確認してみてください。

    動作確認用の環境では最初同じ問題がありましたが、データベースを最初から作り直したら正常に稼動しています。ですのでデバッグモードは必要ないです。
    運用中の環境について、デバッグモードをtrueにしましたが、何のメッセージも表示されません。ファイルに書き込むようにもしてみましたが、1字も出力されませんでした。

    #77042

    yasumax
    キーマスター

    こんにちは。

    ご報告いただきました件につきまして原因がわかりました。
    管理画面[Welcart shop]>[システム設定]にて「ループ表示の際、商品を分離して表示する」にチェックが入っていると商品が表示されないことがわかりました。

    対応策を検討し修正版を出しますので、今しばらくおまちください。

    #77048

    mamekichi
    Participant

    yasumax 様
    こんにちは
    ありがとうございます。
    こちらでも、チェックを外すと表示され、チェックすると表示されないことを確認しました。修正版をお願いします。

    #77145

    mamekichi
    Participant

    yasumax 様

    修正版 Welcart Basic 1.1.0 をインストールしました。
    無事表示されることを確認しました。
    ありがとうございました。

7件の投稿を表示中 - 1 - 7件目 (全7件中)

このトピックに返信するにはログインが必要です。