WordPress がプラグイン Welcart e-Commerce でエラーを捉えました。

ホーム フォーラム バグ報告 WordPress がプラグイン Welcart e-Commerce でエラーを捉えました。

タグ: 

このトピックには5件の返信が含まれ、2人の参加者がいます。2 ヶ月、 2 週間前 nanbu さんが最後の更新を行いました。

6件の投稿を表示中 - 1 - 6件目 (全6件中)
  • 投稿者
    投稿
  • #87943

    welcartmisuooi
    参加者

    WordPress のバージョン:WordPress 5.2.2
    Welcart のバージョン: 1.9.20
    PHP のバージョン:(例 5.6) 7
    Welcart専用の拡張プラグイン: DLSeller
    ご利用のテーマ:アフィンガー5
    症状を確認したブラウザ:グーグルクローム
    サーバー:mixhost
    SSLの利用: 常時SSL

    こんにちは!

    WordPress 5.2から、サイトでプラグインやテーマが致命的なエラーを発生させた場合にそれを検知してこの自動メールでお知らせする機能が追加されました。

    今回の場合、WordPress がプラグイン Welcart e-Commerce でエラーを捉えました。

    welcartが使えない根本的なエラーです。おそらく他の皆さんにも今日6月30日にきているはずです。早く直さないと利益が出ません、訴えられますよ。

    #87948

    nanbu
    参加者

    こんにちは

    PHPのバージョンは7.いくつですか?

    ご利用の DLSeller のバージョンはいくつですか?

    エラーが出ているのでしたら、エラーメッセージを見せていただけますか?

    #87966

    welcartmisuooi
    参加者

    まずはじめに、ご自分のサイト (https://********.com/) を開き、表示上の問題がないか確認してください。次に、エラーが発生したページ (https://********.com/wp-admin/admin.php?page=usces_orderlist&order_action=pdfout&noheader=true&order_id=8785&type=bill&uscesid=MDVjM3E3NmwyOWUxMmZqNWJoOGtmMXBwNGlxN2dhMG41M2M4NjkzXzIwMi4yMzMuMjAuNl8wX0E%) を開き、表示上の問題がないか確認してください。

    この問題をさらに調査するにはサーバーホストに連絡してみてください。

    エラー詳細
    ===============
    エラータイプ E_COMPILE_ERROR が /home2/vsqlvqae/public_html/********.com/wp-content/plugins/usc-e-shop/includes/order_print.php ファイルの 4 行目で発生しました。 エラーメッセージ: require_once(): Failed opening required ‘/home2/vsqlvqae/public_html/*********.com/wp-content/plugins/usc-e-shop/pdf/tcpdf/tcpdf.php’ (include_path=’.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php’)

    となっています。phpのバージョンは調べ方が分かりません。適当に7と書きました

    #87976

    nanbu
    参加者

    PHPのバージョンは、管理画面「Welcart Shop -ホーム-」の下段の「ご利用環境」に表示されています。PHPの欄をコピペして見せてください。

    DLSeller のバージョンは、管理画面「プラグイン」の一覧にWCEX DL Sellerがありバージョン番号が記載されています。

    いずれも、原因を特定したい場合は重要な情報となりますのでご提供ください。

    エラーメッセージではtcpdf.phpというファイルが無いと言っているようですが、Welcartのアップグレードでエラーが出たり、異常に時間がかかったりしてはいなかったでしょうか。

    弊社の環境では、このようなエラーは出ておりません。他にこのようなエラーが出ているユーザーの方がいらっしゃいましたら、こちらのレスをお願いいたします。

    #87981

    welcartmisuooi
    参加者

    PHPの欄をコピペです。

    5.6.40 memory[global]:128M [locale]:256M [usage]:100M
    simplexml, curl, gd, json, mbstring, mysql, openssl

    DLSeller のバージョン

    このプラグインは Welcart 専用のダウンロード販売用拡張プラグインです。Welcart 本体と一緒にご利用ください。

    バージョン 3.0.7

    となっています。

    >Welcartのアップグレードでエラーが出たり、異常に時間がかかったりしてはいなかったでしょうか。

    とのことですが、最近wordpressを4.9代から5.22にあげました。

    その後、数日してダウンロードできないというお客様が現れたとおもったら

    こんにちは!

    WordPress 5.2から、サイトでプラグインやテーマが致命的なエラーを発生させた場合にそれを検知してこの自動メールでお知らせする機能が追加されました。

    今回の場合、WordPress がプラグイン Welcart e-Commerce でエラーを捉えました。

    とメールが来た次第です。

    #87988

    nanbu
    参加者

    Welcart を最新(1.9.20)にした際は問題は無かった。
    WordPressを最新(5.2.2)にして突然ダウンロードができなくなったという事ですね。

    WordPressのエラー検知ではtcpdf.phpがインクルードできないと言ったものでしたが、このファイルはDLSellerのダウンロードとは全く関係のないものです。つまり、あなたのサイトでは今いろんなところで予期しないことが起こっていると解釈できます。

    メモリーの[usage]が100Mと出ていますが、[global]が128M、[locale]が256Mとなっています。これを[global]も256Mになるように設定できますか?

    サーバーのエラーログを見ればすぐにわかることですが、私はメモリーオーバーによる症状ではないかと推測しています。WordPressをアップグレードしたことで、使用メモリが増えたのではないかと思います。

6件の投稿を表示中 - 1 - 6件目 (全6件中)

このトピックに返信するにはログインが必要です。