WP更新後(4.9)のPHPファイルが更新できない

2017 年 11 月 20 日

ホーム フォーラム バグ報告 WP更新後(4.9)のPHPファイルが更新できない

このトピックには4件の返信が含まれ、2人の参加者がいます。2 週間、 6 日前 Confide さんが最後の更新を行いました。

5件の投稿を表示中 - 1 - 5件目 (全5件中)
  • 投稿者
    投稿
  • #84630

    Confide
    参加者

    ——————————————-
    WordPress のバージョン:(4.9)
    Welcart のバージョン:(1.9.6)
    Welcart専用の拡張プラグイン:(なし)
    ご利用のテーマ:(Welcart Default Themeの子テーマ)
    症状を確認したブラウザ:Chrome,firefox
    サーバー:(LoliPop)
    SSLの利用:()
    WordPress のパーマリンク設定:(/%category%/%postname%/)
    ——————————————–

    テーマの編集からphpファイルを更新すると、「致命的なエラーをチェックするためにサイトと通信できないため、PHP の変更は取り消されました。SFTP を使うなど、他の手段で PHP ファイルの変更をアップロードする必要があります。」
    というエラーが出て編集できない。

    納品が近いため、早急な対応を必要としております。
    ご面倒をおかけして恐縮ではございますが、ご回答のほど、宜しくお願いいたします。

    • このトピックは Confideが3 週間、 3 日前に変更しました。
    #84637

    yasumax
    キーマスター

    こんにちは。

    WelcartではなくWordPress4.9の機能のようです。
    「コーディング機能の強化」項目を参照してください。
    WordPress Codex 日本語 Version 4.9

    テーマの編集・プラグインの編集から間違ったコードを書いてしまい管理画面にログインできなくなる場合がありますし、コードを含んだ編集の時は、基本FTPクライアントなどを利用して修正すべきかと思います。

    【 追記 】
    どうしてもテーマの編集から修正されたい場合、WordPress公式のフォーラムにて相談してみてはいかがでしょうか。

    • この返信は3 週間、 2 日前に  yasumax さんが編集しました。理由: 【追記】を追加
    #84646

    Confide
    参加者

    キーマスター様

    お世話になります。
    早速のご対応、ありがとうございました!!

    現在の症状を詳しくご説明しますと、
    プラグインの有効化・無効化を試してみたのですが、
    Welcartを有効化した時のみ、PHPファイルの更新がでなくなるので、ご質問させて頂きました。

    考えられる原因など御座いますでしょうか?

    お忙しいところ大変恐縮ですが、ご協力のほど、宜しくお願い致します。

    #84659

    yasumax
    キーマスター

    こんにちは。

    Welcart側で何か制限をかけるということはしていません。
    また、色々試してみましたがご報告いただいた症状を再現することができませんでした。。

    ネットやSNSでの情報ですが、
    ・PHPバージョンによっても挙動が異なる
    ・2バイトの文字列を保存できない
    など症状が様々なようです。

    公式サポートフォーラムにても色々検証を進めている最中のようですが、解決には至っていないようです。

    今後アップデートがかかるかもしれませんが、FTPクライアントで編集することを強くお勧めいたします。

    #84662

    Confide
    参加者

    キーマスター様

    お世話になっております。

    ご丁寧な回答、ありがとうございました!!
    こちらでも、様々な環境で試してみたのですが、やはり同じ症状でした・・・
    WPの仕様なんですかね、、、
    今後、アップデートされて改善させるまでFTPで直接作業を行うようにいたします。

    また何かありましたら、ご質問させてください。
    ありがとうございました。

5件の投稿を表示中 - 1 - 5件目 (全5件中)

このトピックに返信するにはログインが必要です。