zeusコンビニ決済でお客様入金後のCGI送信301エラー

ホーム フォーラム 使い方全般 zeusコンビニ決済でお客様入金後のCGI送信301エラー

このトピックには5件の返信が含まれ、2人の参加者がいます。3 日、 5 時間前 jywell さんが最後の更新を行いました。

6件の投稿を表示中 - 1 - 6件目 (全6件中)
  • 投稿者
    投稿
  • #85415

    jywell
    参加者

    ——————————————
    WordPress のバージョン:4.9.4
    Welcart のバージョン:1.9.9
    Welcart専用の拡張プラグイン:SKU Select、Poplink
    ご利用のテーマ:自作テーマ
    サーバー:さくらサーバー
    SSLの利用:常時SSL
    WordPress のパーマリンク設定:/%postname%/
    ——————————————–

    お世話になります。

    zeusのコンビニ決済を利用中です。
    注文自体はうまくいくのですが、
    お客様が入金した際にゼウスからのCGI送信がエラーになり
    注文管理画面の情報が入金済みに代わりません。

    ゼウスの管理画面のCGI送信エラーのエラーメッセージは
    HTTP/1.0 301 Moved Permanently
    です。

    CGIの送付先は
    ドメイン+/index.php?acting=zeus_conv
    ですし、
    TOPページにリダイレクトは勿論かけていません。
    どういった原因が考えられるでしょうか。
    ご教授よろしくお願いいたします。

    #85440

    nanbu
    参加者

    こんにちは

    リダイレクトがかかるのは、http:// でアクセスされているためかと思います。
    ZEUSの管理画面を見て、入金お任せの結果通知URLがhttps:// になっているかを確認してみてください。

    #85441

    jywell
    参加者

    ご返信ありがとうございます。

    送信先ポート 443
    Method GET
    URL ドメイン/index.php?acting=zeus_conv&status=<STATUS>&order_no=<ORDD>&clientip=<IPCODE>&money=<KING>&telno=<TELNO>&email=<EMAIL>&username=<NAME>&sendid=<ID>&sendpoint=<POINT>&pay_cvs=<PAY_CVS>&pay_limit=<PAY_LIMIT>&pay_no1=<PAY_NO1>&pay_no2=<PAY_NO2>&error_code=<ERROR_CODE>

    となっておりました。
    ポートは443ですがURLの方にはhttpsがついてないので、
    ゼウスの方に確認してみます。
    ありがとうございます。

    #85456

    nanbu
    参加者

    では、WordPressの一般設定でのURLはいかがですか?

    2つのURLは共に https:// となっていますか?

    また、HTTPS 関連のプラグインは使用していませんか?

    #85473

    jywell
    参加者

    >2つのURLは共に https:// となっていますか?
    https:// ドメイン
    となっております。

    >また、HTTPS 関連のプラグインは使用していませんか?
    特に利用しておりません。

    ゼウスの方の回答がまだ帰ってきていないので、
    やはりそちらの方の設定がおかしかったのかもしれません。

    #85651

    jywell
    参加者

    送信URLからindex.phpを外し、
    ドメイン/?acting=zeus_conv&status=<STATUS>&order_no=<ORDD>&clientip=<IPCODE>&money=<KING>&telno=<TELNO>&email=<EMAIL>&username=<NAME>&sendid=<ID>&sendpoint=<POINT>&pay_cvs=<PAY_CVS>&pay_limit=<PAY_LIMIT>&pay_no1=<PAY_NO1>&pay_no2=<PAY_NO2>&error_code=<ERROR_CODE>
    としたところ
    CGIエラーは解決しました。

    ただ、
    入金があっても
    woerdpress側のステータスは未入金のままです。
    一応デフォルトのwelcartをインストールして
    テストしましたが、
    未入金のままでした。

    どういった原因が考えられますでしょうか。

    • この返信は3 日、 5 時間前に  jywell さんが編集しました。
6件の投稿を表示中 - 1 - 6件目 (全6件中)

このトピックに返信するにはログインが必要です。