newcomer

動作の不具合の検証には環境情報が必要です。投稿の際は下記の情報をお書き添えください。
-------------------------------------------
WordPress のバージョン:(例 5.6)
Welcart のバージョン:(例 2.1.1)
PHP のバージョン:(例 7.4)
Welcart専用の拡張プラグインとバージョン:(例 DL Seller 3.0.8、SKU Select 1.1.4)
ご利用のテーマ:(例 WelcartBasic の自作子テーマ)
症状を確認したブラウザ:
サーバー【重要】:(会社名、サービス名)
--------------------------------------------

フォーラムへの返信

12件の投稿を表示中 - 1 - 12件目 (全12件中)
  • 投稿者
    投稿
  • 返信先: 商品情報欄追加の希望 #59883
    newcomer
    参加者

    遅くまでお疲れさまです。

    WP、Welcart双方のアップグレードを終え、カスタムフィールドに値を入れて、single_item.phpにthe_metaを入れたのですが表示無し…

    get_post_meta() 関数試してみます。

    ちょうどこちらに目を通して良かったです。

    アドバイスありがとうございます。

    返信先: 商品情報欄追加の希望 #59881
    newcomer
    参加者

    ご返信ありがとうございます。

    <div class=”exp”>の後ろにthe_metaを入れると言うことでよろしいでしょうか?

    カスタムフィールドを使うにはどちらともバージョンアップしなければならないので、挑戦してみます。

    single_item.php の退避方法については、フォーラムの記述通りおこないました。独自テーマでしたので理解するのに少し手間取りましたが問題無く動作しています。

    newcomer
    参加者

    追記

    SSL認証のため犠牲にしたと書いたcformsですが、設定で「cformsヘッダーデータを特定のページのみに含める 」というのがありました。

    これでSSL部分でheadの外部読み込みが消えて、プラグインを生かしてSSLに接続出来ました。

    newcomer
    参加者

    検証の結果を報告します。

    nanbu様に見て頂いた時点での問題として、Windows IE6~7でのセキュリティー警告(SSL以外のページでもアクセス毎に)の表示と、Mac firefox3.6で依然SSL認証されないと言う2点(safariでは問題無し)がありました。

    通常はhttpで始まるgoogle mapのscriptが引っかかると思い、手書きでhttpsにしていたのですが、このせいでIEでセキュリティー警告が出てました。

    元に戻すと警告は消えたのですが新たに、カートページに入る時と出る時に「セキュリティ情報 このページにはセキュリティで保護されている項目と保護されていない項目が含まれています。保護されていない項目を表示しますか?」と表示。

    当然の動作だと思いgoogle mapのscriptに条件分岐をかけようと思い見つけました。

    http://ja.forums.wordpress.org/topic/3093

    単一ページの<head>内にスクリプトを入れたいのですが…

    PHPの分かる方ならすぐに出来る事なのでしょうが、おかげでMac Windows環境共にSSL認証する事ができました。

    最終的にプラグイン(cforms)をひとつ犠牲にする事になりましたが、とりあえず次に進めます。

    nanbu様どうもありがとうございました。

    また、よろしくお願いします。

    newcomer
    参加者

    お手数をおかけします。

    Windows Firefoxで確認しましたら、SSL有効になってました。

    たぶんプラグインcformsを外した結果だと思えます。

    現状httpsでアクセスしているのはgooglemapだけだと思います。

    IE6でもセキュリティーの警告が出ているので、ここらへんの検証もふくめて、またご報告します。

    大変助かりました。

    ありがとうございます。

    newcomer
    参加者

    head内をいろいろいじってるのですがまだ成果ありません。

    プラグインはたくさん入ってます。

    確認したところでは

    AVH Extended Categories Widgets→wp_headに特別な表示無し

    Breadcrumb NavXT→wp_headに特別な表示無し

    cforms→cssとjavascriptの読み込み有り(停止)

    Google XML Sitemaps→wp_headに特別な表示無し

    HeadSpace2→wp_headに特別な表示無し

    Lightbox 2→head内に<!– lightboxoffmeta = (Checked kny) –>と表示されるが、javascriptの読み込み等は無いようなので停止してません。(停止して確認もしていますが変化無し)

    MobilePressNEO→wp_headに特別な表示無し

    Post Thumbs→wp_headに特別な表示無し

    Widget Context→wp_headに特別な表示無し

    WP Multibyte Patch→wp_headに特別な表示無し

    My Page Order→wp_headに特別な表示無し

    以上です。一応全てのプラグインをひとつづつですが停止してheadないの表記を確認しました。

    そのほかではhead内のCSSとjqueryはhttpsになってますしgooglmapのscriptはhttpsに書き直しました。

    footerにはgoogle analyticsのscriptがありますがこちらも問題無いようです。

    コンテンツ内の画像などはすべて相対パスで書いてるので問題無いと思いますが…

    これで何か分かりますでしょうか

    newcomer
    参加者

    お世話になります。

    書き方がややこしくて申し訳ありません。

    使っているのは共有SSLです。

    https://lhx02.linkclub.jp/サブドメイン/

    今、突き当たっている問題はカートページに進むと上記のURLになるにもかかわらず、「認証」されない事です。暗号化されてないと表示されます。(Windows IETesterのIE8ではカートページから1ページ毎にセキュリティーの警告がでます。)

    しかしルートに置いたテスト用のhtmlファイルにアクセスすると…

    https://lhx02.linkclub.jp/サブドメイン/test.html

    上記のURLで認証の表示とサーバー会社名、暗号化されている事が確認出来ます。

    と、ここまで書きながら、nanbu様の投稿を何度も読み直しサイトを確認し直して分かったのは、「他のプラグインがインクルードするスタイルシートなどのリンクを変換しきれない」

    問題はこれなんでしょうか?

    確かにFirefoxのページ情報を見ると、1部の接続だけが暗号化されているとの事…headの中もhttpだったり、httpsだったり…

    手動で変えられる部分は書き直して、プラグイン外せるものは外さないとだめですね

    見当違いの事を言ってましたらまた、ご指摘願います。

    newcomer
    参加者

    追記:

    IE6では不安定な動作は無いようです。

    再度、キャッシュクリアして確認してみます。

    ブラウザのせいでしょうか?

    更に検証してみましたところ、不安定な動作はブラウザによるもののようです。

    Mac環境FirefoxをキャッシュクリアしてMac自身も再起動したところ動作安定しました。

    ただしSSL認証されていない状態はそのままです。

    引き続き、ご教授願います。

    newcomer
    参加者

    お世話になります。

    お恥ずかしい限りですが、送料無料条件の覧に5,000円と書き込んでました。

    カートの内容確認で送料の覧が0のままだったのは、送料無料の状態になっていたのだと思います。

    マニュアルの管理室画像を見ていて気がつきました。

    newcomer
    参加者

    更に自己解決したので報告します。

    基本設定の送料無料条件の設定時に問題があったようで、その部分を入力し直したら、送料表示出来るようになりました。

    newcomer
    参加者

    自己解決した部分を報告します。

    商品マスターでの商品画像の表示は出来ました。

    商品コードと画像のファイル名を合わせると表示。

    確認不足でした。

    投稿欄にUPするのだろうと勝手に思ってました。

    しかし依然、カートの内容確認で送料が表示されません。

    運用としては、ひとつの配送方法で複数の支払い方法と言うのが正しいのでしょうか?

    とりあえず配送設定で配送方法と送料をひとつに絞りました。

    商品マスターでは再設定した配送方法と送料が表示されてるのを確認して更新。

    ブラウザのキャッシュも消して再度商品購入しましたが、やはり送料が表示されません。

    何か設定を見落としてるか、間違えてるのだと思うのですが今のところさっぱりわかりません。

    どなたかご指摘お願いいたします。

    返信先: 携帯サイト対応できますか? #59713
    newcomer
    参加者

    ご返答ありがとうございます。

    大変でしょうが期待しております。

    がんばって下さい。

12件の投稿を表示中 - 1 - 12件目 (全12件中)