pacapca

動作の不具合の検証には環境情報が必要です。投稿の際は下記の情報をお書き添えください。
-------------------------------------------
WordPress のバージョン:(例 5.6)
Welcart のバージョン:(例 2.1.1)
PHP のバージョン:(例 7.4)
Welcart専用の拡張プラグインとバージョン:(例 DL Seller 3.0.8、SKU Select 1.1.4)
ご利用の親テーマとバージョン :(例 Welcart Basic 1.4.0)
ご利用の子テーマとバージョン :(例 Welcart Beldad 1.1 )
症状を確認したブラウザ:
サーバー【重要】:(会社名、サービス名)
--------------------------------------------

フォーラムへの返信

4件の投稿を表示中 - 1 - 4件目 (全4件中)
  • 投稿者
    投稿
  • 返信先: [解決済み] SSLについての質問です。 #59358
    pacapca
    参加者

    ご指導ありがとうございます。

    別ドメインで同じサイトを構築直してやってみましたがやはりうまく動作せず、graceさんのご指摘の方法でやってみましたらうまくいきました。

    元のサイトも基本設定データをデフォルトに戻してからやり直してみたところ、うまくいきました。

    本当に初歩的な部分の質問でもお答えいただき助かりました。

    ありがとうございました。

    返信先: [解決済み] SSLについての質問です。 #59355
    pacapca
    参加者

    ありがとうございます。

    ご指摘頂いた通りの現象ですが、システム設定で指定した共有SSLのURLは間違っていないはずです。

    根本的な解決とはいきませんが、カスタムパーマネントリンクをデフォルトと同じ?p=%post_id%に変更したらNotFoundが出ず、うまくいきまいたので、記事や商品の登録ごとにパーマネントリンクの編集をしなくてはいけませんが当面はこれでいこうかと思います。

    返信先: [解決済み] SSLについての質問です。 #59353
    pacapca
    参加者

    早速のお返事ありがとうございます。

    NotFoundになるのは、商品ページからカートへのボタンを押したり、カートページで次へのページを押した場合、SSLを使用したページに移る際になります。

    パーマネントリンクは、デフォルトの/?p=%post_id%から/%category%/%postname%/へ変更しました。

    プラグインは、All in One SEO Pack、Contact Form 7、Executable PHP widget、Executable PHP widget、Twitter Widget Proを使っています。

    カートの初期画面は「url/usces-cart/」となりますが、それより進むと、「共用SSLのurl/?page_id=カートのページナンバー」となります。

    宜しくお願い致します。

    返信先: [解決済み] SSLについての質問です。 #59351
    pacapca
    参加者

    少しお伺いしたいのですが、

    少し前にwelcartを導入したのですが、共用SSLを使用して当初はうまく機能していましたが、

    パーマネントリンクをデフォルトからカスタム構造に変更すると上記の「FileNotFound」の状態になってしまいます。パーマネントリンクをデフォルトに戻すと機能します。

    この場合、どこかを直すことにより対処できるのでしょうか。

    サーバー名:x-server

    Welcartバージョン0.4.4

    です。

    何分初心者なので、何処で質問して良いかも分かりません。解決済みとなっていますが、一番近い内容なのでここに書かせて頂きました。

    使い勝手の良いシンプルなカートシステムでこれからの発展が楽しみです。

    宜しくお願い致します。

4件の投稿を表示中 - 1 - 4件目 (全4件中)