動作の不具合の検証には環境情報が必要です。投稿の際は下記の情報をお書き添えください。
-------------------------------------------
WordPress のバージョン:(例 5.6)
Welcart のバージョン:(例 2.1.1)
PHP のバージョン:(例 7.4)
Welcart専用の拡張プラグインとバージョン:(例 DL Seller 3.0.8、SKU Select 1.1.4)
ご利用のテーマ:(例 WelcartBasic の自作子テーマ)
症状を確認したブラウザ:
サーバー【重要】:(会社名、サービス名)
--------------------------------------------

フォーラムへの返信

6件の投稿を表示中 - 1 - 6件目 (全6件中)
  • 投稿者
    投稿
  • yosi
    参加者

    お久しぶりです。

    まさか約1年前の投稿にコメントが2件も付いているとは思いませんでした。

    あれからバージョンアップする度に、治らないかなと思いつつ該当箇所を削除または、コメントアウトしていました。

    ですが、約3ヶ月前位に気付いてしまったことがありました。

    それは、PHPのバージョンです。

    1年前に投稿した時は、テスト段階時で自宅サーバーで起きていました。

    そしてレンタルサーバーを借りてデモショップにWelcartで作成しました。

    その時、エラーは発生しませんでした。

    でもなぜかは気付かなくて、きっとPHPの設定に違いと思っていました。

    そして3ヶ月位前にふとレンタルサーバーのPHPバージョンをアップしようと確認した所、PHP5.3だったのです。

    自宅サーバーは、PHP5.4でした。

    こちらに対応していませんと記載されていますね。

    https://www.welcart.com/documents/

    レンタルサーバーでPHP5.3と5.4を別々に使用して試したところ、

    5.4では、同じエラーの症状が出ました。

    5.3に変更すると、何事も無かった様にエラーは出ません。

    ですので、このエラーの症状が出る方々は、PHP5.4を使用している可能性が高いと思います。

    原因が分かったので、自宅サーバでは、PHP5.4でそのまま使用しています。

    レンタルサーバーの方は、Welcartを使用する場合は、PHP5.3にしています。

    以上です。

    yosi
    参加者

    こんばんは。

    それが現在は、シングルでwordpressを含めて再インストールしてから

    の状態であります。

    すべてクリアにしてからのスタートでの不具合だったので、原因は

    何なのか想像がつきません。

    確かに後に原因不明の不具合に当たりそうですが、真の解決の糸口が

    私にはありませんので、その時はその時で行くしかないです。

    また何かありましたら投稿させて頂きます。

    ありがとうございました。

    yosi
    参加者

    こんばんは。

    商品編集画面の一番下にリビジョンは表示されています。

    こちらで良かったでしょうか?

    yosi
    参加者

    こんばんは。

    上記エラー表示が解決しました。

    解決した内容は、エラー表示の箇所、

    usceshop.class.phpの2214行目と2215行目の

    2214 $current_screen->post_type = $post->post_type;

    2215 $current_screen->id = $current_screen->post_type;

    これを思い切って削除しました。

    それともう一つ、

    usces_item_master_edit.phpの177,178,253,254行目の

    177 $current_screen->post_type = $post->post_type;

    178 $current_screen->id = $current_screen->post_type;

    253 $current_screen->post_type = $post->post_type;

    254 $current_screen->id = $current_screen->post_type;

    これも削除しました。

    それによってエラー表示がなくなり、ちゃんとした表示がされました。

    (ちゃんとした表示は見たことがないのでわかりませんが・・たぶん)

    その後、新規追加、商品編集など行い、商品表示から買い物までテスト

    特に問題なく動作しています。

    ちなみにContactForm7の編集画面にもでたエラーも表示されません。

    なぜ上記の同じ記述達がエラーの原因になっていたのかは、

    勉強不足のため、分かりません。

    でも、解決できた感じがしますのでスッキリしました。

    皆様、ありがとうございました。

    yosi
    参加者

    こんにちは。

    再度シングルでトライしましたが同じ様になります。

    ワードプレスを新規インストールして、プラグインもwelcartだけに

    して見ましたが、解決できませんでした。

    何か設定が必要な所があるのでしょうか?

    ご指導お願いしたします。

    yosi
    参加者

    こんにちは。

    ご返答ありがとうございます。

    マルチサイトには対応していなかったですか。

    何か、調べると対応してる感じがしましたので・・・。

    承知しました、シングルで再トライします。

    ありがとうございました。

6件の投稿を表示中 - 1 - 6件目 (全6件中)