Re: バージョンアップ後、有効化の際に出たエラーについて

ホーム フォーラム バグ報告 バージョンアップ後、有効化の際に出たエラーについて Re: バージョンアップ後、有効化の際に出たエラーについて

#63719

you
参加者

テスト環境[php5.2.8]にて、welcart1.1.2にアップデートしました。

上記のエラーはなくなりましたが、下記エラーが出てきました。

php:5.2.8

WP:3.3.1

welcart:1.0.10→1.1.2

[Welcart Shop]-[商品情報編集]-[複写して新規]でエラー

Warning: Cannot modify header information – headers already sent by (output started at /home/wpまでのディレクトリ/wp-admin/includes/template.php:1657) in /home/wpまでのディレクトリ/wp-includes/pluggable.php on line 866

→[商品マスター]ページに戻ると、カテゴリーだけ引き継がれた、空の商品情報ページが作成されている。

同じデータで以下環境下でも同じエラー。

php:5.3.5

WP:3.3.1

welcart:1.0.10→1.1.2

現存サイトのデータベースからエクスポートしたデータを、テスト環境にインポートして、「サイトURL」「WPのURL」、だけ変更し、その後管理画面から「SSL関係のURL」を変更して確認しています。

このやり方がまずいのかな、という思いもあります。

テスト環境につき急ぎませんので、お手すきの時にご回答をよろしくお願い致します。

【追記】

アップデート後に、[新規追加]で商品を追加したもので[複写して新規]を行うと、正常にコピーが出てきました。

(php5.2.8、5.3.5共に正常にコピー)

welcart1.0.10とWP3.3.0で正常に動いていた物を、WP3.3.1にバージョンアップするとこのエラーが出て、サーバー上のファイルを消去→アップロードしなおしてWP3.3.0に戻してもこのエラーが出る様になりました。