パーマリンク「投稿名」の時、商品新規登録がおかしい

2014 年 1 月 24 日

ホーム フォーラム 使い方全般 パーマリンク「投稿名」の時、商品新規登録がおかしい

このトピックには2件の返信が含まれ、2人の参加者がいます。3 年、 10 ヶ月前 mars1984 さんが最後の更新を行いました。

3件の投稿を表示中 - 1 - 3件目 (全3件中)
  • 投稿者
    投稿
  • #68675

    mars1984
    参加者

    いつも利用させて頂きありがとうございます。

    件名の新規登録時のおかしな部分ですが
    ・パーマリンクを「投稿名」
    ・商品追加よりも先に画像を追加 <= 再現できたのはこの場合でした
    といった環境で商品の新規追加をすると
    商品ページにSKUやカートといった出力がなく

    <p class=”attachment”></p>

    といった出力のみがされる状態になります。
    2サイト構築中でどちらでも起こったのですが
    念の為、別サーバにWordpressを新規インストールしWelcartのみを有効にした状態でも再現出来ました。(Wordpress3.8の場合も同様)

    パーマリンクを「投稿名」以外にすると正常な商品ページの出力になり
    またこれは正確かどうか微妙ですが、商品追加->画像登録の順番だと正常に出力されます。

    これはバグなのかパーマリンク「投稿名」が使えない仕様なのか、どちらでしょうか?

    ——————————————-
    WordPress のバージョン:3.8.1
    Welcart のバージョン:1.3.11.1401081
    ご利用のテーマ:welcart default (とそれをカスタマイズしたもの)
    症状を確認したブラウザ:chrome,safari,ie
    サーバー(会社名、サービス名):さくらスタンダード,かごや専用サーバ,VPS(nginx)
    SSLの利用:あり・なし両方 
    WordPress のパーマリンク設定:投稿名
    ——————————————–

    #68695

    yskysmr
    キーマスター

    こんにちは。

    仰るとおりの症状を確認いたしました。ご報告ありがとうございました。

    パーマリンクを「投稿名」以外にすると正常な商品ページの出力になり
    またこれは正確かどうか微妙ですが、商品追加->画像登録の順番だと正常に出力されます。

    確かに、「商品追加->画像登録」ですと問題ないようです。もう少し、こちらで検証・調査いたしますので、ご不便をおかけしますが、パーマリンクを「投稿名」でご利用の場合は、「商品追加->画像登録」の順番でご登録をお願いできますでしょうか。

    調査結果は、また改めてこちらのトピックに報告させていただきます。

    よろしくお願いいたします。

    • この返信は3 年、 10 ヶ月前に  yskysmr さんが編集しました。
    #68700

    mars1984
    参加者

    yskysmrさん

    ご返信有難うございます。
    登録の順番、了解致しました。

    いつも使うばかりでしたので報告できて良かったです。
    今後の益々のご発展を祈っております。

3件の投稿を表示中 - 1 - 3件目 (全3件中)

このトピックに返信するにはログインが必要です。