プラグインが勝手に無効化されたが、購入データは残っているのか?

ホーム フォーラム 使い方全般 プラグインが勝手に無効化されたが、購入データは残っているのか?

このトピックには14件の返信が含まれ、4人の参加者がいます。1 ヶ月、 3 週間前 emuninim22 さんが最後の更新を行いました。

15件の投稿を表示中 - 1 - 15件目 (全15件中)
  • 投稿者
    投稿
  • #90630

    emuninim22
    参加者

    お世話になります。
    現在、別のトピックでも聞いていますが、別件での質問です。
    ご教示いただけると幸いです。

    <現在投稿している別トピック>
    https://www.welcart.com/community/forums/topic/%e3%80%8c%e4%bc%9a%e5%93%a1%e7%99%bb%e9%8c%b2%e3%80%8d%e3%80%8c%e3%83%91%e3%82%b9%e3%83%af%e3%83%bc%e3%83%89%e3%82%92%e3%81%8a%e5%bf%98%e3%82%8c%e3%81%a7%e3%81%99%e3%81%8b%ef%bc%9f%e3%80%8d-%e3%80%8c

    今回は上記に対する5.5への対応の一環であれば良いのですが、、、
    プラグインが自動で無効化されてしまいました。

    有効化すると下記のエラーが出てきます。

    懸念は、以下の点です。
    ・ここまでの商品マスタや、受注データは生きているのか?←消えてしまったら死活問題です。
    ・有効化をどのようにすればできるのか?

    恐れ入りますが、回答と解決策をご教示いただけると幸いです。

    ーーーーーーーーーーーーーーーーーーーー
    重大なエラーを引き起こしたため、プラグインを有効化できませんでした。
    Warning: require_once(/wordpress/core/5.5/wp-content/plugins/usc-e-shop/functions/included_first.php): failed to open stream: No such file or directory in /srv/htdocs/wp-content/plugins/usc-e-shop/usc-e-shop.php on line 46

    Fatal error: require_once(): Failed opening required ‘/wordpress/core/5.5/wp-content/plugins/usc-e-shop/functions/included_first.php’ (include_path=’/:.’) in /srv/htdocs/wp-content/plugins/usc-e-shop/usc-e-shop.php on line 46
    ーーーーーーーーーーーーーーーーーーーー

    ——————————————-
    WordPress のバージョン:5.5
    Welcart のバージョン:1.9.31
    PHP のバージョン:7.3.21
    Welcart専用の拡張プラグインとバージョン:(例 DL Seller 3.0.8、SKU Select 1.1.4)
    ご利用のテーマ:ICONIC
    症状を確認したブラウザ:Chrome
    サーバー:WordPress.com のネームサーバーを使用
    SSLの利用:常時SSL
    ——————————————–

    #90632

    Konoha
    参加者

    >emuninim22様

    私はプラグインを使用していませんので、何とも言えませんが、
    ご使用のDL Sellerも今回のWordpress5.5の件でアップデート(3.0.14)されているようです。
    そちらはいかがでしょうか?

    Welcartは強制停止してもデータは消えない仕様だったと思います…

    明確なお返事が出来ず申し訳ございません。

    • この返信は1 ヶ月、 3 週間前に   さんが編集しました。
    #90634

    emuninim22
    参加者

    >konohaさん

    ご連絡をありがとうございました。
    プラグインでなくても利用できる方法があるのですね。

    >運営事務局御中

    転記ミスがありましたので、再度掲載します。
    (特に拡張プラグインは利用していません)

    1.9.32になって、突然有効化ができなくなり、大変困っています。

    対応策をご教示いただけますか?

    <有効化しようとすると出てくるメッセージ>
    ーーーーーーーーーーーーーーーーーーーー
    重大なエラーを引き起こしたため、プラグインを有効化できませんでした。
    Warning: require_once(/wordpress/core/5.5/wp-content/plugins/usc-e-shop/functions/included_first.php): failed to open stream: No such file or directory in /srv/htdocs/wp-content/plugins/usc-e-shop/usc-e-shop.php on line 46

    Fatal error: require_once(): Failed opening required ‘/wordpress/core/5.5/wp-content/plugins/usc-e-shop/functions/included_first.php’ (include_path=’/:.’) in /srv/htdocs/wp-content/plugins/usc-e-shop/usc-e-shop.php on line 46
    ーーーーーーーーーーーーーーーーーーーー

    ——————————————-
    WordPress のバージョン:5.5
    Welcart のバージョン:1.9.32
    PHP のバージョン:7.3.21
    Welcart専用の拡張プラグインとバージョン:特に専用拡張プラグインは利用なし。
    ご利用のテーマ:ICONIC
    症状を確認したブラウザ:Chrome
    サーバー:WordPress.com のネームサーバーを使用
    SSLの利用:常時SSL
    ——————————————–

    #90635

    Konoha
    参加者

    emuninim22様

    サーバーがWordPress.comでしたら、同様のトッピックを発見しました。

    WordPress.com plugin新規インストール後有効化エラー

    ご参考になれば…

    #90636

    emuninim22
    参加者

    Konohaさん

    有難うございます・・!
    これは私も確認しましたが、エラーの箇所が違うようで、再現できませんでした・・。

    発注データが見れなくて、大変困惑しています。
    なんとか解決したいのですが、困りました・・・。

    ーーーーーーーーーーーー
    emuninim22様

    サーバーがWordPress.comでしたら、同様のトッピックを発見しました。

    WordPress.com plugin新規インストール後有効化エラー

    ご参考になれば…
    ーーーーーーーーーーーー

    #90638

    Konoha
    参加者

    emuninim22様

    そうでしたか…
    お役に立てず申し訳ございません。

    wordpress.comのサイトをみると、
    プラグインのインストールはビジネス・eコマースプランでのみ出来るようですが…

    https://ja.wordpress.com/pricing/

    そのあたりは問題ないですよね。

    あとは、現在インストールしている他のプラグインを一つずつ無効しながら確認してみるとか…

    ご参考までに。

    #90643

    emuninim22
    参加者

    Konohaさん

    ご返信をありがとうございます。

    >そのあたりは問題ないですよね。
    >あとは、現在インストールしている他のプラグインを一つずつ無効しながら確認してみるとか…
    >ご参考までに。
    ありがとうございます。
    はい、こちらも問題ないというか、そもそも前のバージョンでも問題なく利用できておりましたので、、
    念のため、既存のプラグインも無効化して見たりして確認いただけました。

    運営事務局様

    かなり危うい状況なので、どうか、お返事をお待ちしております・・・。

    #90653

    yskysmr
    キーマスター

    こんにちは。

    おそらく更新に失敗していると思われます。
    「プラグインが勝手に無効化される」ということはないかと思うのですが、Welcart の更新はどのようにされたでしょうか。プラグイン一覧の「更新してください」のリンクから更新されましたか?
    また、更新時にテーマを Welcart 専用のものでないテーマに切り替えてみてください。

    #90661

    emuninim22
    参加者

    yskysmr様

    ご返信をありがとうございます。

    突然、商品購入ができなくなったと問い合わせが来たので、
    特に何も触っていない状況で、プラグインからWelcartが無効化されておりました。

    1.9.32になった影響かと思い、
    インストール一覧から、再度有効化のボタンを押しましたが、上記のエラーメッセージが出てしまったという状況です。

    ですので、更新をどの様にしたかではなく、「無効化されていたので、再度有効化したらエラーになった」という状況となります。

    更新時のテーマを専用でないものに切り替えて、更新してみます。

    ちなみに、最初の質問にあります通り、今までの商品購入データや顧客データは残っているものでしょうか。
    (とても懸念しています。)

    #90662

    emuninim22
    参加者

    yskysmr様

    お世話になります。

    ただいま、

    ーーーーーーーーーーーー
    更新時にテーマを Welcart 専用のものでないテーマに切り替えてみてください。
    ーーーーーーーーーーーー

    こちらを試しましたが、同様に、下記のエラーが発生します。
    ーーーーーーーーーーーー
    Warning: require_once(/wordpress/core/5.5/wp-content/plugins/usc-e-shop/functions/included_first.php): failed to open stream: No such file or directory in /srv/htdocs/wp-content/plugins/usc-e-shop/usc-e-shop.php on line 46

    Fatal error: require_once(): Failed opening required ‘/wordpress/core/5.5/wp-content/plugins/usc-e-shop/functions/included_first.php’ (include_path=’/:.’) in /srv/htdocs/wp-content/plugins/usc-e-shop/usc-e-shop.php on line 46
    ーーーーーーーーーーーー

    なお、先ほど、一覧から一度削除しての再インストールも試しておりますが同様です。

    大変恐れ入りますが、ご支援いただけますと幸いです。

    8月16日までは商品も問題なく販売できております。

    何卒宜しくお願い致します。

    #90669

    nanbu
    キーマスター

    こんにちは

    1.9.32になって、突然有効化ができなくなり、大変困っています。

    「1.9.32になって・・」とのことですが、1.9.32にはご自分で更新を押してアップグレードされましたか? もしそうでなければ自動更新を設定されていたのではないかと推測します。さらに自動更新の際にエラーが発生したので、プラグインが無効化されたと推測します。

    有効化しようとしたときのエラーを見ますと、どうも必要なファイルが足りていないように見えます。一旦Welcartを削除して、再インストール有効化をしてみてはいかがでしょうか。

    #90677

    emuninim22
    参加者

    nanbu様

    お世話になります。コメントをありがとうございます。

    仰る通りの推測だと思います。

    そして前述の通り、「一覧から一度削除しての再インストールも試しておりますが」

    うまくいきませんでした・・・。

    仰る通り、
    usc-e-shop.php 46行目がうまく読み込めていないというエラーですが、、

    どうしたら良いのでしょうか・・・。

    #90678

    emuninim22
    参加者

    運営事務局御中
    yskysmr様

    お世話になります。

    バージョンが1.9.32になってから、プラグインの有効化にエラーが発生しており、利用ができなくなりました。

    出てくるエラーメッセージは下記になります。
    ———————————————
    Warning: require_once(/wordpress/core/5.5/wp-content/plugins/usc-e-shop/functions/included_first.php): failed to open stream: No such file or directory in /srv/htdocs/wp-content/plugins/usc-e-shop/usc-e-shop.php on line 46

    Fatal error: require_once(): Failed opening required ‘/wordpress/core/5.5/wp-content/plugins/usc-e-shop/functions/included_first.php’ (include_path=’/:.’) in /srv/htdocs/wp-content/plugins/usc-e-shop/usc-e-shop.php on line 46
    ———————————————

    今までに、アドバイスをいただいた下記の対応をしましたが、改善されません。

    ・現在インストールしている他のプラグインを一つずつ無効しながら確認
    ・一度Welcartを削除して、再インストール
    ・更新時にテーマを Welcart 専用のものでないテーマに切り替え

    大変恐れ入りますが、至急、対処策をご教示いただけないでしょうか。

    また、有料のサポートが必要な案件であれば、そちらについてもご教示ください。
    3日間、商品の販売ができなくて一刻を争います。

    宜しくお願い申し上げます。

    ——————————————-
    WordPress のバージョン:5.5
    Welcart のバージョン:1.9.32
    PHP のバージョン:7.3.21
    Welcart専用の拡張プラグインとバージョン:特に専用拡張プラグインは利用なし。
    ご利用のテーマ:ICONIC
    症状を確認したブラウザ:Chrome
    サーバー:WordPress.com のネームサーバーを使用
    SSLの利用:常時SSL
    ——————————————–

    #90680

    yskysmr
    キーマスター

    emuninim22 様

    弊社では WordPress.com での動作検証をしていませんので、アップグレードでどういう挙動になるか、そもそも正常に動作するのか、分かっておりません。よろしければ動作検証させていただきますので、不具合調査のページよりご連絡をいただけますでしょうか。

    #90681

    emuninim22
    参加者

    運営事務局御中
    yskysmr様

    お世話になります。
    ご連絡をありがとうございます。不具合調査のページより連絡をさせていただきます。

15件の投稿を表示中 - 1 - 15件目 (全15件中)

このトピックに返信するにはログインが必要です。