[解決済み] Paypalで完了しない

2012 年 2 月 25 日

ホーム フォーラム 使い方全般 [解決済み] Paypalで完了しない

このトピックには10件の返信が含まれ、2人の参加者がいます。3 年、 4 ヶ月前 mamekichi さんが最後の更新を行いました。

11件の投稿を表示中 - 1 - 11件目 (全11件中)
  • 投稿者
    投稿
  • #51336

    mamekichi
    参加者

    動作に関するご質問の場合は必ずご記入ください。


    WordPress のバージョン:3.3.1

    Welcart のバージョン:1.1.2.1202202

    ご利用のテーマ:welcartのデフォルトをカスタマイズ

    症状を確認したブラウザ:Camino

    サーバー(会社名、サービス名):xrea+

    SSLの利用:  共用SSL

    WordPress のパーマリンク設定:デフォルト


    お世話になります。

    現在1.06で運用中で特に問題は生じておりません。

    1.1xをテスト中です。

    sandboxで動作チェックしたところ完了できませんでした。

    同様のトピックが既にありますが、動作やエラーコードなどが違う様子です。

    現象:

    Paypalで最後に[今すぐ支払う]をクリックすると エラー ご注文が完了しませんでした。 (error 1)の画面に戻ります。

    acting_transaction.logには

    PayPal : DoExpressCheckoutPayment API call failed. Error Code:[10525] Error Severity Code:[Error] Short Error Message:Invalid Data Detailed Error Message:This transaction cannot be processed. The amount to be charged is zero.

    と書かれています。

    関係あるかどうかわかりませんが、functions.phpに、以前教えていただいた下記の修正は加えています。

    add_filter('usces_sessid_force', 'my_sessid_force');
    function my_sessid_force( $notuse ){
    return 'NONEADDR';
    }

    何かfunctions.phpに加えなければならないようなことがあるでしょうか? よろしくお願い申し上げます。

    #63934

    mamekichi
    参加者

    追記

    1.0.10.1201241にダウングレードして試したところ、エラーは表示されず「完了」のページが表示されました。

    しかし、

    Warning: unserialize() expects parameter 1 to be string, array given in /virtual/<ユーザ名>/public_html/<サイト>/wp-content/plugins/usc-e-shop/functions/item_post.php on line 1969

    というワーニングが2回出ています。

    #63935

    nanbu
    参加者

    こんにちは。

    v1.1にアップグレードした場合はDBをもとに戻さない限りダウングレードはできません。v1.0では正常に動作しませんのでv1.1をご利用ください。

    mamekichiさんもPHPは5.3ですか?

    #63936

    mamekichi
    参加者

    おせわになります。

    PHPは5.2.5でした。

    v1.0は試しに使ってみただけです。

    再び1.1.2にアップグレードして調べてみます。

    (続き)

    1.1.2.1202171 にしましたが、結果は同じでした。

    #63937

    nanbu
    参加者

    Development Versionにアップグレードお願いできますでしょうか。バージョンは1.1.2.1202202となります。

    http://downloads.wordpress.org/plugin/usc-e-shop.zip

    もしこのバージョンでもダメな場合、よろしければサイトを調査させていただけますでしょうか。よろしければ下記宛にご連絡ください。

    nanbuアットusconsort.com(アットは@)

    #63938

    mamekichi
    参加者

    1.1.2.1202202に再びアップしましたが、最初と同じでした。

    functions.phpには、先に教えていただいたコードをコメントアウトして、技術資料にあったコードを書きました。

    メールを差し上げましたのでご覧下さい。

    #63939

    nanbu
    参加者

    すみません、xreaをお使いでしたね。

    こちらの対処法で改善しませんでしょうか。

    http://support.welcart.com/133/

    こちらは外してください。

    add_filter('usces_sessid_force', 'my_sessid_force');
    function my_sessid_force( $notuse ){
    return 'NONEADDR';
    }

    #63940

    mamekichi
    参加者

    お忙しいところお世話になります。

    先の投稿で、「技術資料にあったコード」と書いたのは、

    http://support.welcart.com/133/

    のことです。重複するのでご指摘の古いコードを外して上記のコードと入れ替えています。

    結果は同じでした。エラーとなって決済できません。

    サイトを調査いただけるように、nanbu様宛にメールを差し上げております。よろしくお願い申し上げます。

    #63941

    nanbu
    参加者

    サイトを拝見させていただきました。

    どうやら、SSLでのクッキーが何故かちゃんと取得できないことがわかりました。Welcart1.1ではSSLでのクッキーを使用してセキュリティーを高めて

    いますので、今回このような状態になったと思われます。

    他のサーバーでは今のところ問題なくクッキーは取得できていますので

    とりあえずXrea特有の症状ということで対応したいと思います。

    セキュリティが下がります(旧バージョンと同じです)が、以下の

    フィルターで対応できます。ご利用のテーマ内のfunctions.phpに設置してください。

    add_filter( 'usces_filter_cookie', 'my_filter_cookie'); function my_filter_cookie($nouse){
    return true;
    }

    ご協力ありがとうございました。

    #63942

    mamekichi
    参加者

    大変お世話になりました。

    セキュリティが下がるということで残念ですが、フィルター設置後の動作を確認しました。

    ありがとうございました。

    #71436

    mamekichi
    参加者

    こんにちは

    Wordpress 3.9.1
    Welcart Version 1.4.3.1406281
    PHP 5.3.28

    coreserverがアップデート(apache2.2、php標準が5.3。5.4、5.5も可)されたので、チェックをしています。

    こちらのフィルターは不要になった模様です。
    削除してもPaypalの決済でエラーが生じること無く、Welcartの画面にもどる最後まで正常に終了しました。

11件の投稿を表示中 - 1 - 11件目 (全11件中)

このトピックに返信するにはログインが必要です。