過去バージョンのダウンロード方法

ホーム フォーラム インストール 過去バージョンのダウンロード方法

このトピックには5件の返信が含まれ、2人の参加者がいます。2 ヶ月、 2 週間前 genkia さんが最後の更新を行いました。

6件の投稿を表示中 - 1 - 6件目 (全6件中)
  • 投稿者
    投稿
  • #89567

    genkia
    参加者

    回答いただける方ありがとうございます。

    現在業務の引き継ぎを受け初めてWelCartをいじっているのですが、一点質問があります。

    私達のシステムではカスタムオーダーフィールドに対してラッピングをつけているのですが、
    ラッピングが500円で指定していて消費税がかかるときになぜか8%になってしまい、540円の請求が表示されるようになっています。

    別のトピックで質問させていただいたところ、独自カスタマイズされているとのことでした。
    https://www.welcart.com/community/forums/topic/%e3%82%ab%e3%82%b9%e3%82%bf%e3%83%a0%e3%83%bb%e3%82%aa%e3%83%bc%e3%83%80%e3%83%bc%e3%83%95%e3%82%a3%e3%83%bc%e3%83%ab%e3%83%89%e3%81%b8%e3%81%ae%e6%b6%88%e8%b2%bb%e7%a8%8e%e9%81%a9%e5%bf%9c

    そのため差分を確認しながら修正をしていこうと思っているのですが、
    何かしらの方法で バージョン 1.9.10 をダウンロードする方法はないのでしょうか?

    どなたかご回答いただけないでしょうか?
    よろしくおねがいします。

    ——————————————-
    WordPress のバージョン:(4.9.4)
    Welcart のバージョン:(1.9.10)
    PHP のバージョン:(5.2.4)
    ご利用のテーマ:(自作テーマ)
    症状を確認したブラウザ:すべて(Safari, Firefox)
    サーバー:(Monaca)
    SSLの利用:(例 常時SSL)
    ——————————————–

    #89574

    yskysmr
    キーマスター

    こんにちは。

    「WelCartをいじっている」とのことですが、Welcart 本体のソースコードを改変されているということでしょうか。

    本日、WordPress 5.4 がリリースされました。PHP の推奨バージョンは、7.3 以降となっています。古いバージョンの WordPress、Welcart、PHP のご利用を続けられることはお勧めできません。新しいバージョンに合わせて、フックを利用してカスタマイズを行っていただきますよう、お願いいたします。

    #89680

    genkia
    参加者

    ご回答ありがとうございました!
    そうですね。Welcart本体のソースコードが改変されています。
    そのためバージョンを上げる前に一度編集箇所等を確認してから更新しようと考えています。

    すみません!PHPのバージョンが一応7.0.8になっていたのでメジャーアップデートにはならないかなぁと思っています。PHPのバージョンも今から上げていく予定ですが、念の為の共有です。

    そのため今後の作業内容としては
    1. Welcart のバージョン:(1.9.10)で差分確認
    2. PHP&Wordpress&プラグインのバージョン上げ
    3. 差分部分をfunctions.phpを子テーマで作成して反映
    のようにしていく予定です!!

    いかんせん、差分の確認ができないので手間をとっているので過去バージョンのダウンロード方法を探しているという現状です。

    • この返信は2 ヶ月、 3 週間前に  genkia さんが編集しました。
    #89682

    yskysmr
    キーマスター

    genkia 様

    Welcart の過去のバージョンは、以下よりダウンロードできます。

    ▼Welcart プラグインページ
    https://ja.wordpress.org/plugins/usc-e-shop/advanced/

    #89686

    genkia
    参加者

    yskysm様

    ありがとうございます!!!
    ダウンロードできました!!

    #89687

    genkia
    参加者

    yskysm様

    ちなみに皆さんはどのようにバージョンアップで影響が出ない形で機能追加など行っているのでしょうか?
    子テーマのようにはプラグインってできないですよね?

6件の投稿を表示中 - 1 - 6件目 (全6件中)

このトピックに返信するにはログインが必要です。