phpのバージョンアップとwelcert1.8インストールについて

2016 年 4 月 11 日

ホーム フォーラム インストール phpのバージョンアップとwelcert1.8インストールについて

このトピックには8件の返信が含まれ、2人の参加者がいます。11 ヶ月、 2 週間前 hidetatsu さんが最後の更新を行いました。

9件の投稿を表示中 - 1 - 9件目 (全9件中)
  • 投稿者
    投稿
  • #78095

    hidetatsu
    Participant

    ——————————————-
    WordPress のバージョン:4.4.2
    Welcart のバージョン:1.7.2
    ご利用のテーマ:Welcart Default Theme / 独自テーマ
    症状を確認したブラウザ:Google Chrome バージョン 48.0.2564.103 m
    サーバー(会社名、サービス名):xserver
    SSLの利用:あり
    WordPress のパーマリンク設定:数字ベース / カスタム構造
    ※WCEX DL Sellerを使用しています。versionは2.1.7です。
    ——————————————–

    この度、PHPのバージョンを5.3.3から5.6にアップグレードすることとなりました。
    その際の確認なのですが、
    PHP v5.3.3の状態で、welcertのバージョンを1.8にアップグレードしてから
    phpをv5.6にアップグレードすれば不具合なく更新できますでしょうか?

    たま、本ホームページ:最新情報項目の「Welcart 1.8 をリリースしました」の内容に、
    「v1.4 未満からのアップグレードの場合は、Welcartを停止してからアップグレードを行ってください。」とありますが、v1.7なので、welcertを停止しない状態でアップグレードしても問題ないのでしょうか?
    オンラインマニュアルにはプラグインを停止してから行うようにと記載されています。仕様が変わったのでしょうか?

    お手数おかけしますが、ご返信よろしくお願い致します。

    #78102

    nanbu
    Participant

    こんにちは

    仰る通り、WelcartをアップグレードしてからPHPをアップデートしてください。
    先ほどWelcart1.8.1をリリースいたしましたので、1.8.1をご利用ください。

    停止してから更新と言う操作は、データベースの変更を行った時に必要なものですが、原則的にWelcartは停止してから更新をしていただくのが良いかと思います。

    #78113

    hidetatsu
    Participant

    nanbu様

    早急にご連絡頂き感謝いたします。

    すみません、もう一点確認させてください。
    welcertのプラグインと共に、DL Sellerも使用しております。
    こちらについても、PHPのバージョンを上げても特に問題ありませんでしょうか?
    ※たまにnoticeログを出力しています。
    [11-Apr-2016 05:45:32 UTC] PHP Notice: Undefined index: dlseller_member_reinforcement in /vagrant/wordpress/wp-content/plugins/wcex_dlseller/wcex_dlseller.php on line 1429
    ※こちらは、welcert1.8.1に更新後のログになります。

    フォーラム、販売サイトなど確認してみましたが、記載を見つけることが出来ませんでした。

    お手数おかけしますが、ご返信よろしくお願い致します。

    #78116

    hidetatsu
    Participant

    連続の投稿失礼します。

    Download商材を購入時のnotice ログを添付いたします。
    こちらも合わせてご確認ください。

    以上、よろしくお願い致します。

    Attachments:
    You must be logged in to view attached files.
    #78147

    nanbu
    Participant

    まずは、DLSellerもWelcartに合わせてアップグレードしていただけますでしょうか。

    #78150

    hidetatsu
    Participant

    nanbu様

    ご連絡ありがとうございます。
    DLSellerのサイトにアップされている最新verは2.1.14になるかと思います。
    現在、使用させて頂いているものは、ver.2.1.7 となります。
    ※以前、バグの対応頂いた際に、バグFix版の正式リリース時期が不明確のため別途ファイルを提供頂きました。

    これより新しいものがあるのでしょうか?その場合、どちらからダウンロードできますしょうか?
    サイトにログインしてメンバーページから最新版をダウンロードしたところ、ver2.1.14がダウンロードされました。
    ちなみに、DLSellerの最新版はWordpressのプラグイン画面からアップデートはできないのでしょうか?

    お手数おかけしますがご確認、ご返信よろしくお願い致します。

    #78156

    hidetatsu
    Participant

    nanbu様

    申し訳ありません。
    DLSellerのバージョンについて、勘違いしておりました。
    サイトより、2.2.14をダウンロードし、確認したいと思います。

    こちらのアップはずっと見逃していました。。。
    wordpressのプラグインに通知が来るようにするのは難しいのでしょか?

    更新履歴を確認させて頂きました。

    ダウンロード&サービス販売拡張プラグイン DLSeller


    特にPHPのバージョンに関する記載がありませんが、5.6でも問題なく動作しますでしょうか?

    お手数ですが、ご確認よろしくお願い致します。

    #78186

    nanbu
    Participant

    弊社も開発環境PHP5.6に移行いたしましていますが、各プラグイン正常に動作していることを確認しています。

    #78189

    hidetatsu
    Participant

    nanbu様

    ご連絡ありがとうございます。
    ご返信の件、了解いたしました。

    また、何かありましたらご対応よろしくお願い致します。

9件の投稿を表示中 - 1 - 9件目 (全9件中)

このトピックに返信するにはログインが必要です。