PHPをバージョンアップすると警告が出る

フォーラム 使い方全般 PHPをバージョンアップすると警告が出る

  • このトピックには2件の返信、2人の参加者があり、最後にfurutaにより3週、 6日前に更新されました。
3件の投稿を表示中 - 1 - 3件目 (全3件中)
  • 投稿者
    投稿
  • #101816
    mita79
    参加者

    PHPを7.4.33から8.1.22にバージョンアップしたところ下記の警告が出ます。

    Warning: Attempt to read property “ID” on null in /home/hokuogohan/”サイトURL”/public_html/store/wp-includes/link-template.php on line 394

    Warning: Attempt to read property “ID” on null in /home/hokuogohan/”サイトURL”/public_html/store/wp-includes/link-template.php on line 445

    Warning: Attempt to read property “ID” on null in /home/hokuogohan/”サイトURL”/public_html/store/wp-includes/link-template.php on line 456

    Warning: Attempt to read property “ID” on null in /home/hokuogohan/”サイトURL”/public_html/store/wp-includes/link-template.php on line 409

    詳しくないので、対処方法が分からず困っています。どのように対応すればよいのかお教えいただけますか?

    ——————————————-
    WordPress のバージョン:6.5.2
    Welcart のバージョン:2.10.2
    PHP のバージョン:7.4.33
    Welcart専用の拡張プラグインとバージョン:WCEX Google Analytics4 1.0.6 WCEX Yamato Number 1.2.2
    ご利用の親テーマとバージョン : Welcart Basic 1.8.4
    ご利用の子テーマとバージョン : Child for Welcart Basic 1.3.1
    症状を確認したブラウザ:Chrome
    サーバー【重要】:Xサーバー
    ——————————————–

    #101817
    mita79
    参加者

    PHPを7.4.33から8.1.22にバージョンアップしたところ下記の警告が出ます。

    Warning: Attempt to read property “ID” on null in /home/●●●●●/”サイトURL”/public_html/store/wp-includes/link-template.php on line 394

    Warning: Attempt to read property “ID” on null in /home/●●●●●/”サイトURL”/public_html/store/wp-includes/link-template.php on line 445

    Warning: Attempt to read property “ID” on null in /home/●●●●●/”サイトURL”/public_html/store/wp-includes/link-template.php on line 456

    Warning: Attempt to read property “ID” on null in /home/●●●●●/”サイトURL”/public_html/store/wp-includes/link-template.php on line 409

    詳しくないので、対処方法が分からず困っています。どのように対応すればよいのかお教えいただけますか?

    ——————————————-
    WordPress のバージョン:6.5.2
    Welcart のバージョン:2.10.2
    PHP のバージョン:7.4.33
    Welcart専用の拡張プラグインとバージョン:WCEX Google Analytics4 1.0.6 WCEX Yamato Number 1.2.2
    ご利用の親テーマとバージョン : Welcart Basic 1.8.4
    ご利用の子テーマとバージョン : Child for Welcart Basic 1.3.1
    症状を確認したブラウザ:Chrome
    サーバー【重要】:Xサーバー
    ——————————————–

    #101824
    furuta
    キーマスター

    mita79 様

    こんにちは。
    ご利用の子テーマ内に PHP8.1に対応していないコードがないかご確認いただけますでしょうか。もし可能であれば親テーマ「Welcart Basic」に切り替えて症状をご確認いただけたらと思います。※切り替え後に症状が改善される場合には子テーマが原因の可能性が考えられます。

3件の投稿を表示中 - 1 - 3件目 (全3件中)
  • このトピックに返信するにはログインが必要です。