Welcart2.8での自動更新無効化について

フォーラム インストール Welcart2.8での自動更新無効化について

  • このトピックには6件の返信、7人の参加者があり、最後にparashoeにより1年、 7ヶ月前に更新されました。
7件の投稿を表示中 - 1 - 7件目 (全7件中)
  • 投稿者
    投稿
  • #98489
    kotarou
    参加者

    ——————————————-
    WordPress のバージョン:6.0.1
    Welcart のバージョン:2.7.3
    PHP のバージョン:7.3.15
    ご利用のテーマ:Welcart Beldad
    サーバー:さくらのレンタルサーバ
    SSLの利用:常時SSL
    ——————————————–

    お世話になっております。
    Welcart2.8へのアップデートに伴い、
    マイナーアップデートの時は自動更新する機能を実装とのことでしたが、
    テスト環境で確認してみたところ自動更新をオフにすることができないようでした。

    こちらの都合で恐縮なのですが、
    プラグイン本体内のプログラムを編集して無理やりカスタマイズを入れている箇所があるため、
    反映・動作確認をしてからアップデートしたいと考えております。
    自動更新はオフにすることはできないでしょうか。

    #98504
    furuta
    キーマスター

    kotarou 様

    こんにちは。
    大変申し訳ありませんが、そういった使い方は推奨いたしておりません。マイナーアップデートには、緊急性の高い修正が含まれる場合もございます。Welcart のカスタマイズにはフックを利用していただき、アップデートに影響のないカスタマイズをしていただけますよう、お願いいたします。
    尚、「ここにフックを追加して欲しい」というご要望は承りますので、ご相談いただけたらと思います。

    #99153
    natsworks
    参加者

    2022/12/15の 「バージョン 2.8.7」の自動アップデートが原因でwelcartプラグインサイトがいくつか壊れてしまいました。クリスマスキャンペーン中+広告を入れてる状況で昼間にサイトが壊れるのは大変な事態なので、自動アップデートはやはり無効化できるようにしてもらいたいです。

    また、バージョン 2.8.7が正常化ご確認ください。

    ——————————————-
    WordPress のバージョン:6.1.1
    Welcart のバージョン:2.8.6
    PHP のバージョン:7.4.28
    ——————————————-

    #99155
    stkuc
    参加者

    Development Version を使用することで緊急回避できました。

    #99156
    takahashiei
    参加者

    お世話になっております。
    バージョン 2.8.7、私が管理しているサイトでも、不具合が出て、サイトが見られない状況でした。
    今はリカバリーモードから2.8.6に戻して運用中なので正確なエラーメッセージが見られませんが、/wordpress/wp-content/plugins/usc-e-shop/extensions/OperationLog/class-operation-log.phpがrequire_onceできないといったメッセージが出ました。
    このままだとまた同じ状況になると思うので、やはり自動アップデートは無効化できるのが良いと思います。
    とり急ぎご報告まで。
    宜しくお願いいたします。

    #99161
    sagawa
    キーマスター

    natsworks様
    stkuc様
    takahashiei様

    Welcartの2.8.7の自動更新時におっしゃる通りの症状になる場合があることを確認いたしました。
    FTPクライアントツールでWelcartプラグイン(usc-e-shop)を削除いただき、再度管理画面からWelcartをインストールしてみていただけますでしょうか?

    もし、ご自身での対応が難しい場合は、こちらのWelReからFTP情報を添えてご連絡いただけますでしょうか?
    こちらで対応させていただきます。

    #99167
    parashoe
    参加者

    私も一時サイトが非表示になってししまいましたが、
    リカバリーモードから、Welcart2.8.8へ更新したら直りました。

7件の投稿を表示中 - 1 - 7件目 (全7件中)
  • このトピックに返信するにはログインが必要です。