WordPress.com plugin新規インストール後有効化エラー

ホーム フォーラム インストール WordPress.com plugin新規インストール後有効化エラー

このトピックには6件の返信が含まれ、3人の参加者がいます。1 ヶ月、 3 週間前 jundai さんが最後の更新を行いました。

7件の投稿を表示中 - 1 - 7件目 (全7件中)
  • 投稿者
    投稿
  • #90184

    jundai
    参加者

    WordPress.comでの契約直後にほぼ近い状態(サイト名などを設定した状態のみ、DNS設定を自身のサイトに向けたのみ)より。有効化時に次のエラーが出ており、先に進めずにおります。
    対処法をアドバイスいただけないでしょうか。

    Warning: require_once(/wordpress/core/5.4.2/wp-content/plugins/usc-e-shop/functions/included_first.php): failed to open stream: No such file or directory in /srv/htdocs/wp-content/plugins/usc-e-shop/usc-e-shop.php on line 46
    
    Fatal error: require_once(): Failed opening required '/wordpress/core/5.4.2/wp-content/plugins/usc-e-shop/functions/included_first.php' (include_path='/:.') in /srv/htdocs/wp-content/plugins/usc-e-shop/usc-e-shop.php on line 46

    ——————————————-
    WordPress のバージョン:WordPress 5.4.2
    Welcart のバージョン:バージョン 1.9.30
    PHP のバージョン:7.3
    Welcart専用の拡張プラグインとバージョン:初期状態まだなし。
    症状を確認したブラウザ:Chrome
    サーバー:WordPress.com
    SSLの利用:有効
    ——————————————–
    再現手順
    (1)WordPressの管理パネルで、プラグイン>新規プラグインに移動し、Welcart e-Commerceを検索し、 [今すぐインストール] をクリックします。
    (2)プラグインの一覧ページで Welcart e-Commerceより、
     [有効化]をクリック
    (3)上記のFatalエラーで停止

    #90222

    yskysmr
    キーマスター

    こんにちは。

    WordPress.com の無料プランをご利用でしょうか。無料プランでは外部プラグインは利用できなかったかと思います。

    #90297

    jundai
    参加者

    >こんにちは。
    >WordPress.com の無料プランをご利用でしょうか。無料プランでは外部プラグインは利用できなかったかと思います。

    ご返答遅く申し訳ないです。返信ありがとうございます。
    無料プランではなく、有料プランです。

    困っています。

    #90306

    jundai
    参加者

    以下のように切り替えて動作しましたが、気になることあればどなたでもコメントください。
    usc-e-shop.php

    //define(‘USCES_PLUGIN_DIR’, USCES_WP_PLUGIN_DIR . ‘/’ . plugin_basename(dirname(__FILE__)));

    define(‘USCES_PLUGIN_DIR’, plugin_dir_path(__FILE__));

    初心者には難易度が高いですね。2週間はかかりました。
    動作するかも不安です。

    • この返信は3 ヶ月、 4 週間前に  jundai さんが編集しました。
    #90703

    jundai
    参加者

    改めまして、この改修は、うまくいかないようです。
    Welcartの自動更新のたびに元のコードに戻り、同等のエラーが発生して
    サイトのWelcartプラグインが無効化されてしまいます。

    よき対処策を教えていただければと思います。

    Wordpress.comに質問を投げることも可能です。
    困りました。WelcartだとWordpress.comで全く立ち上がらないです。

    回避策としてご存知の方も教えて欲しいです。
    決まったコードを必ず直す必要がある場合、皆さんはどのように適用していますか。
    自動パッチなど当てないと無効になるたびにあげなおす必要があります。
    自動アップデート無効が単純な対処策だとは思うのですが、特定の場所を書き換えさえすれば動くということなのですが。

    #90712

    nanbu
    キーマスター

    こんにちは

    Welcartを修正してみました。下記のDevelopmentバージョンをダウンロードいただき入れ替えてみていただけますでしょうか。
    https://downloads.wordpress.org/plugin/usc-e-shop.zip

    どうぞよろしくお願いいたします。

    #90746

    jundai
    参加者

    お返事遅れました。本件で解決しています。ありがとうございます。

7件の投稿を表示中 - 1 - 7件目 (全7件中)

このトピックに返信するにはログインが必要です。