fransis6667

動作の不具合の検証には環境情報が必要です。投稿の際は下記の情報をお書き添えください。
-------------------------------------------
WordPress のバージョン:(例 5.6)
Welcart のバージョン:(例 2.1.1)
PHP のバージョン:(例 7.4)
Welcart専用の拡張プラグインとバージョン:(例 DL Seller 3.0.8、SKU Select 1.1.4)
ご利用の親テーマとバージョン :(例 Welcart Basic 1.4.0)
ご利用の子テーマとバージョン :(例 Welcart Beldad 1.1 )
症状を確認したブラウザ:
サーバー【重要】:(会社名、サービス名)
--------------------------------------------

注意

Welcart 2.7 アップデートによる不具合の問い合わせについて

Welcart 2.7 にアップデート後にショップデータ更新を行う必要があります。
ほとんどのサイトでは問題なく完了しますが、サーバースペックなどの問題でショップデータ更新が途中で止まることがございます。
更新が完了しない方は WelRescue の不具合調査からご連絡ください。

ご連絡いただく前に、アップデート前のバックアップを利用して元の状態に戻してください。
また、以下の情報を必ずご連絡ください。
  1. ご利用のサーバー会社とプラン
  2. システム環境情報

フォーラムへの返信

3件の投稿を表示中 - 1 - 3件目 (全3件中)
  • 投稿者
    投稿
  • fransis6667
    参加者

    解決いたしました.
    ありがとうございます.

    fransis6667
    参加者

    ありがとうございます.

    私が大変無知でして,本来推奨されないことだったのですね.
    これからは一才いじらないことにします.

    編集した箇所についてですが,エラーが出てから変更箇所を消去し,データの上書きを行いました.
    wio_defaultというのも追加した一部なのですが,エラーが出てコードから完全に消去しました.
    ただエラー文には変わらず表示されております.

    get_field()に関しましても.変更した二つのphpファイルで検索をしてみましたが
    どこにも記述がないようでした.

    素人的な考えで大変申し訳ないのですが,こちら,二つのファイルを初期化することはできないのでしょうか.

    この度は私の安易な考えでこのようなエラーを起こしてしまいましたが,
    これから商品登録も控えていまして,大変困っている状況です.

    お手数ですが,アドバイスいただけると大変嬉しいです.
    よろしくお願いいたします.

    fransis6667
    参加者

    エラー詳細がメールで届いておりました.
    エラー詳細
    ===============
    エラータイプ E_ERROR が /home/fransis/fransis.jp/public_html/official/wp-content/plugins/usc-e-shop/includes/usces_item_master_list.php ファイルの 405 行目で発生しました。 エラーメッセージ: Uncaught Error: Call to undefined function get_field() in /home/fransis/fransis.jp/public_html/official/wp-content/plugins/usc-e-shop/includes/usces_item_master_list.php:405
    Stack trace:
    #0 /home/fransis/fransis.jp/public_html/official/wp-content/plugins/usc-e-shop/classes/usceshop.class.php(543): require_once()
    #1 /home/fransis/fransis.jp/public_html/official/wp-includes/class-wp-hook.php(292): usc_e_shop->item_master_page(”)
    #2 /home/fransis/fransis.jp/public_html/official/wp-includes/class-wp-hook.php(316): WP_Hook->apply_filters(”, Array)
    #3 /home/fransis/fransis.jp/public_html/official/wp-includes/plugin.php(484): WP_Hook->do_action(Array)
    #4 /home/fransis/fransis.jp/public_html/official/wp-admin/admin.php(259): do_action(‘welcart-shop_pa…’)
    #5 {main}
    thrown

    加えて,記載のバージョンが間違っておりました.
    訂正させていただきます.
    ——————————————-
    WordPress のバージョン:5.7.4
    Welcart のバージョン:2.3.4
    PHP のバージョン:7.4.25
    ——————————————–

3件の投稿を表示中 - 1 - 3件目 (全3件中)