h-miyakura

動作の不具合の検証には環境情報が必要です。投稿の際は下記の情報をお書き添えください。
-------------------------------------------
WordPress のバージョン:(例 5.6)
Welcart のバージョン:(例 2.1.1)
PHP のバージョン:(例 7.4)
Welcart専用の拡張プラグインとバージョン:(例 DL Seller 3.0.8、SKU Select 1.1.4)
ご利用のテーマ:(例 WelcartBasic の自作子テーマ)
症状を確認したブラウザ:
サーバー【重要】:(会社名、サービス名)
--------------------------------------------

フォーラムへの返信

2件の投稿を表示中 - 1 - 2件目 (全2件中)
  • 投稿者
    投稿
  • 返信先: welcartログイン #83754
    h-miyakura
    参加者

    ——————————————-
    WordPress のバージョン:(4.8-ja)
    Welcart のバージョン:(1.9.3)
    Welcart専用の拡張プラグイン:(使用していません)
    ご利用のテーマ:(Welcar-basic)
    症状を確認したブラウザ:chrome
    サーバー:(***)
    SSLの利用:(SSL非対応)
    WordPress のパーマリンク設定:(/%postname%/)
    ——————————————–

    yskysmr 様

    ——————————————-
    WordPress のバージョン:(4.8-ja)
    Welcart のバージョン:(1.9.3)
    Welcart専用の拡張プラグイン:(使用していません)
    ご利用のテーマ:(Welcar-basic)
    症状を確認したブラウザ:chrome
    サーバー:(***)
    SSLの利用:(SSL非対応)
    WordPress のパーマリンク設定:(/%postname%/)
    ——————————————–

    yskysmr 様

    質問の趣旨が曖昧だったので、追記いたします。

    add_filter( ‘usces_filter_login_inform’, ‘my_filter_login_inform’ );
    function my_filter_login_inform() {
    return ‘<input type=“password” name=“dummy_pass” style=“visibility:hidden;top:-100px;left:-100px;” />‘;
    }

    を追記したところ、トップページでは事象が解決されたのですが、その他のログインフォームでは事象が解決されていません。
    そこで、上記filterの第一引数を変更することにより、welcart-basic内の全てのログインフォームを一括でフィックスする術がないかをご確認したいというのが質問の趣旨です。

    ページごとに第一引数を変更するしかないのでしょうか?

    よろしくお願いいたします。

    返信先: welcartログイン #83752
    h-miyakura
    参加者

    ——————————————-
    WordPress のバージョン:(4.8-ja)
    Welcart のバージョン:(1.9.3)
    Welcart専用の拡張プラグイン:(使用していません)
    ご利用のテーマ:(Welcar-basic)
    症状を確認したブラウザ:chrome
    サーバー:(***)
    SSLの利用:(SSL非対応)
    WordPress のパーマリンク設定:(/%postname%/)
    ——————————————–

    yskysmr 様

    ご回答ありがとうございます。
    トップページにおける当該現象は、functions.phpに上記コードを追記することで解消致しました。
    しかし、カート処理の「お客様情報」ページで、従来の現象が再現しております。

    [引用]回避策として、hidden のパスワードフィールドを設置すると、初期表示がされなくなるそうです[/引用]

    上記引用文以外でなにか解決策があれば、ご教示いただければ幸いです。

    よろしくお願いいたします。

2件の投稿を表示中 - 1 - 2件目 (全2件中)