動作の不具合の検証には環境情報が必要です。投稿の際は下記の情報をお書き添えください。
-------------------------------------------
WordPress のバージョン:(例 5.6)
Welcart のバージョン:(例 2.1.1)
PHP のバージョン:(例 7.4)
Welcart専用の拡張プラグインとバージョン:(例 DL Seller 3.0.8、SKU Select 1.1.4)
ご利用のテーマ:(例 WelcartBasic の自作子テーマ)
症状を確認したブラウザ:
サーバー【重要】:(会社名、サービス名)
--------------------------------------------

フォーラムへの返信

7件の投稿を表示中 - 1 - 7件目 (全7件中)
  • 投稿者
    投稿
  • ikuki
    参加者

    再度、アップグレードを実行してみましたところ、welcart1.0から1.4への更新が出来ました。

    プラグインの停止を行った上でのWPバージョンアップをしなかったのが原因ぽいと考えております。(前は、WPをアップデートして、プラグインを「停止」→「有効化」で対応していた)

    ikuki
    参加者

    ご回答ありがとうございます。

    ひとまず、php5.4にて対応が出来るようなので、ダウングレードして対応します。

    丁寧にお付き合いいただき感謝いたします。

    ありがとうございます。

    ikuki
    参加者

    ご回答ありがとうございます。

    php5.4への対応は可能だと思いますが、php5.6だと具体的にはどのような問題が起こりますか?
    テスト環境でphp5.6を動かしているのですが、今のところ問題は無いと思いますが・・・

    ikuki
    参加者

    お返事を頂きありがとうございます。

    PHPのバージョンは、5.1.17から5.6.1になります。

    また、アップデートの手順のご紹介もありがとうございます。

    DBのバックアップもありますし、welcartのアップデートも停止の上実行してみましたが、上手くできませんでした。

    なので、諦めて基本設定を再設定して、動作テストをして問題なさそうなので、
    そのまま行こうと思っています。

    WPのアップデートの段階で、wp_optionsの内部か構造的な部分で不具合が出て基本設定に影響を及ぼしているのではないかと考えております。

    一応、再検証のため別DBでご回答いただいた方法で再度アップデートを実行してみたいと思います。

    返信先: 購入完了後のカート内商品 #63346
    ikuki
    参加者

    <?php wp_footer(); ?>

    入ってませんでした。

    ありがとうございます。

    ikuki
    参加者

    なるほど、hiddenですか!

    やってみます。

    ありがとうございます。

    ikuki
    参加者

    phpの関数入れ間違いでした。

    すみません。

    <div class=”breadcrumb”>

    <?php

    if(function_exists(’bcn_display’))

    {

    bcn_display();

    }

    ?>

    </div>

    のbcn_display();をbcn_display_list();

    と書いてしまってたのが原因でした。

7件の投稿を表示中 - 1 - 7件目 (全7件中)