Welcart のインストールでエラーが出て有効化できない

この記事は最終更新日から1年以上が経過しています。

自動アップグレード・手動アップグレード・FTPでのアップグレードのいずれの方法でも、エラーが出る、或いは途中で止まってしまって正常に有効化できない。

要因として次のことが挙げられます。

他のプラグインとの競合

競合するプラグインと併用することで、様々な不具合が発生します。競合するプラグイン一覧を確認して、環境にあった選択を行ってください。

Welcart と競合するプラグイン一覧

対応していない PHP のバージョンを使っている

Welcart のバージョンによって、対応しているPHPのバージョンが異なります。
下記ページに対応表がありますので、こちらを確認してください。

対応バージョン

PHPメモリー不足(memory_limit)

使用するメモリーが制限(memory_limit)を超えるとエラーとなります。
この値は環境や商品点数によって異なりますが、128~512MBあるいはそれ以上が必要となる場合がございます。