「配送設定」が設定できない

2017 年 1 月 23 日

ホーム フォーラム 使い方全般 「配送設定」が設定できない

タグ: 

このトピックには8件の返信が含まれ、2人の参加者がいます。7 ヶ月、 3 週間前 kmt2017 さんが最後の更新を行いました。

9件の投稿を表示中 - 1 - 9件目 (全9件中)
  • 投稿者
    投稿
  • #81862

    kmt2017
    参加者

    管理画面の「配送設定」
    http://xxxx/wp-admin/admin.php?page=usces_delivery
    のみ内容が表示されず空白で設定ができなくなりました。
    管理画面のヘッダー、フッター、左メニューや
    welcartの他の設定項目は正常に表示されます。

    過去のトピック「配送方法の追加が出来ません」

    配送方法の追加が出来ません

    を参考にしてみましたが、改善されません。
    他に対処法がありますでしょうか。
    ——————————————-
    WordPress のバージョン:4.7.1
    Welcart のバージョン:1.9.1
    ご利用のテーマ:Responsive (1.9.9.0)
    症状を確認したブラウザ:chrome 55 / IE 11 / firefox 50
    サーバー(会社名、サービス名):さくらインターネット PHPバージョン 5.6
    SSLの利用: なし
    WordPress のパーマリンク設定:投稿名
    ——————————————–
    使用プラグイン
    Akismet (3.2)
    AntiVirus (1.3.9)
    brBrbr (2.0)
    Contact Form 7 (4.7)
    Custom Post Type Permalinks (2.2.0)
    Custom Post Type UI (1.5.1)
    Google XML Sitemaps (4.0.8)
    Meteor Slides (1.5.6)
    PHP Code Widget (2.3)
    PHP Execution (1.0.0)
    Responsive Add Ons (1.0.7)
    TinyMCE Advanced (4.4.3)
    WCEX Item List Layout (1.2.7)
    Welcart e-Commerce (1.9.1)
    WP Multibyte Patch (2.8.1)
    WP Social Bookmarking Light (1.8.8)
    WP-DBManager (2.78.1)

    ——————————————–
    試したこと

    ・全プラグイン 停止
    ・テーマをwelcart defaultに変更
    ・ブラウザキャッシュを消去

    chrome/IE/firefoxでも同様にしてみましたが改善されませんでした。

    よろしくお願いします。

    #81874

    yskysmr
    キーマスター

    こんにちは。

    Welcart Shop>ホーム>ご利用の環境のところをコピーしてお知らせください。
    また、サーバーの WAF の設定が ON になっていたら OFF にしてください。

    #81879

    kmt2017
    参加者

    返信ありがとうございます。

    > Welcart Shop>ホーム>ご利用の環境のところをコピーしてお知らせください。

    ●ご利用環境
    サーバー Apache/2.2.31
    MySQL 5.5.38
    PHP 5.6.27 memory[global]:128M [locale]:256M [usage]:15M
    simplexml, curl, gd, json, mbstring, mysql, openssl

    > また、サーバーの WAF の設定が ON になっていたら OFF にしてください。

    OFFに変更しました。

    よろしくお願いします。

    #81890

    yskysmr
    キーマスター

    kmt2017 様

    ご利用環境は問題ありません。

    > > また、サーバーの WAF の設定が ON になっていたら OFF にしてください。
    > OFFに変更しました。
    OFF にしても、症状は変わらないということでしょうか。

    「配送設定画面のみ空白になる」というのは、どういう症状でしょうか。キャプチャを見せてもらうことはできますか?

    #81894

    kmt2017
    参加者

    yskysmr様

    ありがとうございます。

    > > > また、サーバーの WAF の設定が ON になっていたら OFF にしてください。
    > > OFFに変更しました。
    > OFF にしても、症状は変わらないということでしょうか。

    はい、OFFにして
    ・全プラグイン 停止
    ・テーマをwelcart defaultに変更
    ・ブラウザキャッシュを消去
    など試してみても変わりませんでした。

    > 「配送設定画面のみ空白になる」というのは、どういう症状でしょうか。キャプチャを見せて> もらうことはできますか?

    はい。キャプチャを載せますのでご確認ください。

    Attachments:
    You must be logged in to view attached files.
    #81899

    yskysmr
    キーマスター

    kmt2017 様

    ブラウザの検証機能で、JavaScript のエラーが出ていないか確認してみてくださいますか。

    #81903

    kmt2017
    参加者

    yskysmr様

    chromeの要素を検証から確認しましたが、エラーは出ていないようです。

    ですが、ソースを確認したところ、

    		<script type="text/javascript">
    jQuery(function($){
    
    	$(".charge_text").bind("change", function(){ usces_check_money($(this)); });
    	$(".days_text").bind("change", function(){ usces_check_num($(this)); });
    
    	var target_market = [];
    	target_market[0] = "JP";
    	var base_country = "JP";
    
    	var delivery_method = [];
    	delivery_method[0] = [];
    	delivery_method[0]['id'] = 0;
    	delivery_method[0]['name'] = "";
    	delivery_method[0]['charge'] = 0;
    	delivery_method[0]['days'] = 0;
    	sttr = '';
    		delivery_method[0]['time'] = sttr;
    	delivery_method[0]['nocod'] = "";
    	delivery_method[0]['intl'] = "0";
    	delivery_method[1] = [];
    	delivery_method[1]['id'] = 0;
    	delivery_method[1]['name'] = "";
    	delivery_method[1]['charge'] = 0;
    	delivery_method[1]['days'] = 0;
    	sttr = '';
    		delivery_method[1]['time'] = sttr;
    	delivery_method[1]['nocod'] = "";
    	delivery_method[1]['intl'] = "0";
    	delivery_method[2] = [];
    	delivery_method[2]['id'] = 0;
    	delivery_method[2]['name'] = "";
    	delivery_method[2]['charge'] = 0;
    	delivery_method[2]['days'] = 0;
    	sttr = '';
    		delivery_method[2]['time'] = sttr;
    	delivery_method[2]['nocod'] = "";
    	delivery_method[2]['intl'] = "0";

    というように
    delivery_method[0] から
    delivery_method[18687]まで並んでおり、
    delivery_method[18687]の途中で切れ、
    それ以降のタグが読み込まれていない状態でした。

    welcartの再インストールが必要でしょうか?

    Welcart e-Commerce プラグインを削除し、
    データベース内の
    テーブル「options」>option_name 「usces」を削除し
    再インストールするという方法ではだめでしょうか?

    #81910

    yskysmr
    キーマスター

    kmt2017 様

    確かに、配送設定の設定内容が壊れているように見えます。
    配送設定はまだ一度も設定したことがないのでしょうか。それとも、以前は見えていたのでしょうか。

    いずれにしましても、この状態からの配送設定の内容の復旧は難しいかもしれません。

    #81918

    kmt2017
    参加者

    yskysmr様

    配送設定は最初は設定できておりました。
    数日前に内容を変更した際、おかしくなりました。

    色々とありがとうございます。

    再インストールしてみますm(_ _)m

9件の投稿を表示中 - 1 - 9件目 (全9件中)

このトピックに返信するにはログインが必要です。