dongri

動作の不具合の検証には環境情報が必要です。投稿の際は下記の情報をお書き添えください。
-------------------------------------------
WordPress のバージョン:(例 5.6)
Welcart のバージョン:(例 2.1.1)
PHP のバージョン:(例 7.4)
Welcart専用の拡張プラグインとバージョン:(例 DL Seller 3.0.8、SKU Select 1.1.4)
ご利用の親テーマとバージョン :(例 Welcart Basic 1.4.0)
ご利用の子テーマとバージョン :(例 Welcart Beldad 1.1 )
症状を確認したブラウザ:
サーバー【重要】:(会社名、サービス名)
--------------------------------------------

フォーラムへの返信

8件の投稿を表示中 - 1 - 8件目 (全8件中)
  • 投稿者
    投稿
  • dongri
    参加者

    ikeda 様

    ご返信ありがとうございます。
    さっそく、「Friendly Functions for Welcart 1.1.5」を停止してみたところ、
    直りました~!!
    迅速なご対応、誠にありがとうございます。

    今後は、アイキャッチ画像を編集する際は、Friendly Functions for Welcart をいったん停止しようと思います。
    ありがとうございました。

    dongri
    参加者

    ikeda 様

    ご返信ありがとうございます。
    「Image Uploader for Welcart」プラグインの方は、Image Uploader コンバーターを導入後に停止していることを確認しましたが、アイキャッチ画像の編集・削除・追加ができない状態です。

    具体的には、
    ・welcartをアップグレード前に登録していた『アイキャッチ画像を削除』をクリックしても、なにも起こらない。
    ・Welcart Shop 新規商品追加のページで新規にアイキャッチ画像を設定しようとすると、メディアライブライは開くのですが、画像を選択して『アイキャッチ画像を設定』ボタンをおしても、アイキャッチ画像に反映されない。
    という症状です。

    何卒、よろしくお願いいたします。

    dongri
    参加者

    お世話になっております。
    V2.6.3にアップデートして、アイキャッチ画像の編集を試みたのですが、やはり編集・削除・追加ができない状態が続いてます。
    welcartの拡張機能の新しい商品画像登録を無効にしても状況は変わりません。

    次期バージョンで、アイキャッチ画像の追加修正のご予定はございますでしょうか。
    何卒、よろしくお願いいたします。

    以下、当方の情報です。
    ——————————————-
    WordPress のバージョン:5.9.3-ja
    Welcart のバージョン:2.6.3
    PHP のバージョン:7.4.28
    Welcart専用の拡張プラグインとバージョン:Friendly Functions for Welcart 1.1.5
    ご利用の親テーマとバージョン :15年ほど前のホームページビルダー内に収録されていたワードプレスのテーマ
    ご利用の子テーマとバージョン :子テーマは作成していません。
    症状を確認したブラウザ:crome
    サーバー【重要】:さくらインターネット スタンダードプラン
    ——————————————–

    dongri
    参加者

    迅速なご対応ありがとうございます!

    welcartの拡張機能で、新しい商品画像登録を無効にしても、状況は変わりませんでした。

    それでは、修正の方をお待ちしております。

    dongri
    参加者

    お返事ありがとうございます。

    解決いたしましたので、ご報告いたします。

    セキュリティ対策として、wp-adminにアクセスをIPで限定する.htaccessを追加していたため
    admin-ajax.phpにアクセスできなかったのが原因でした。

    自分が使用しているwifi環境のIPはhtaccessでアクセス許可にしてあったため、wifiだけ決済できる現象になってしまっていました。(- -;)
    大変お手数をおかけいたしました。

    dongri
    参加者

    furuta 様

    連投して申し訳ございません。
    関係あるかわかりませんが、黒色ボタンの『デビットカードまたはクレジットカード』が表示される場合と、最初のGマークのような形しか表示されない場合がありましたので、お知らせいたします。

    〇・・[G デビットカードまたはクレジットカード]と表示される場合
    x・・[ G ]

    iphoneの場合(crome と safari どちらも同じでした。) 携帯の向き:縦
    御社デモサイト   自社サイト
    wifi   ×          〇
    4G    ×          〇

    アンドロイドの場合(ブラウザ crome) 携帯の向き:縦
    御社デモサイト   自社サイト
    wifi   ×          ×
    4G    ×          ×

    よろしくお願いいたします。

    dongri
    参加者

    furuta様

    お返事ありがとうございます。

    – 常時SSL化の設定について。–
    welcartを導入させていただいたサイトは2サイトありまして、
    一つは、独自ドメインで常時SSL化。もう一つは、さくらレンタルサーバの初期ドメインで、共有SSLを使っています。
    2サイトとも、下記4点の手順をおこなっております。
    1.SSLの導入(さくらレンタルサーバの管理画面にて導入)
    2.WordPressの設定を変更する
    3.Welcartの設定を変更する
    4.http:// でのアクセスを https:// にリダイレクト(ワードプレスのURLをhttpsにするだけでリダイレクトするようですが、念のため、さくらの管理画面にてリダイレクトの設定済み)

    また、2サイトのどちらも、今回の同じ不具合が起こっています。
    以下は、さくらレンタルサーバの初期ドメインで共有SSLを使っている方を、再度、welcart 最新バージョン2.2.2に変更して動作確認した結果です。

    [iphone6S システムバージョン14.4.2 ブラウザcrome での挙動]
    御社デモサイト
     wifi環境・・・黄色ボタン paypalのサイトが別窓で開きます。
             黒色ボタン クレジットカード情報の入力窓が下にスライド表示されます。
     4G環境・・・ wifi環境と同じでした。

    当方のショッピングサイト welcart2.2.2
     wifi環境・・・黄色ボタン paypalのサイトが別窓で開きます。
             黒色ボタン クレジットカード情報の入力窓が下にスライド表示されます。
     4G環境・・・ 黄色ボタン 一瞬読み込みマークが出て、すぐに消えてペイパルのサイトに移行せず。
             黒色ボタン ボタンを押しても反応しません。

    [iphone6S システムバージョン14.4.2 ブラウザsafari での挙動]
    御社デモサイト
    ブラウザcromeと同じ動作でした。

    当方のショッピングサイト welcart2.2.2
     wifi環境・・・ブラウザcromeと同じ動作でした。

     4G環境・・・ 黄色ボタン 読み込みマークが出て、ずっと読み込み中になってしまいます。
             黒色ボタン ボタンを押しても反応しません。

    [アンドロイド SO-01K バージョン9 ブラウザcrome での挙動]
    御社デモサイト
     wifi環境・・・黄色ボタン paypalのサイトが別窓で開きます。
             黒色ボタン クレジットカード情報の入力窓が下にスライド表示されます。
     4G環境・・・ 黄色ボタン paypalのサイトが別窓で開きます。
             黒色ボタン スライド表示はせず、別窓でpaypalのサイトのカード入力画面が開きます。

    当方のショッピングサイト welcart2.2.2
     wifi環境・・・黄色ボタン paypalのサイトが別窓で開きます。
             黒色ボタン クレジットカード情報の入力窓が下にスライド表示されます。
     4G環境・・・黄色ボタン 一瞬読み込みマークが出て、すぐに消えてペイパルのサイトに移行せず。
            黒色ボタン ボタンを押しても反応しません。

    ※アンドロイドの方は、ブラウザsafariがはいっていないため、cromeのみテストしました。

    ————
    御社のテストサイトでは問題なく動作いたしますので、スマホの問題ではなく、はやり当方のサイトに問題があることがわかりました。
    また、アンドロイドのみですが、御社デモサイトの黒色ボタンで、wifi環境と4G環境で挙動が異なるので、機種や通信方法によってpaypalの処理が少し異なる?ような気もします。

    もし何かお分かりになりましたら、ご教授くださいませ。
    よろしくお願いいたします。

    dongri
    参加者

    furuta 様

    お返事ありがとうございます。
    Welcart2.1以上にアップグレード後の設定は、お貼りいただいたリンク先どおり設定いたしました。
    何度かやり直してみましたが、改善されません。

    3台のスマホと2か所のwifi環境で試しましたが、すべて同じ挙動です。

    ・wifi環境のスマホやPCですと、黄色ボタン『Paypalで支払う』と黒色ボタン『デビットカードまたはクレジットカード』は問題なく決済画面が表示されて、決済処理も完了します。

    ・4G環境に切り替えたスマホですと、google cromeだと黄色と黒色のボタンのどちらを押してもボタンが反応しません。safariですと、黒色ボタンは同じく反応せず、黄色いボタンはPaypalのサイトに移行するのですが読み込み状態のまま動かなくなってしまいます。

    wifiと4G回線という通信方法の違いで、ボタンの挙動が異なる理由がわからない状況です。。

    ワードプレスのプラグインが原因かと思い、キャッシュ系プラグインとjava・cssの最適化プラグインを停止しましたが改善されませんでした。
    また、サイトをhttps化するプラグインは削除しましたが、改善されませんでした。

    レンタルサーバは、さくらレンタルサーバ のスタンダードなのですが、何かの設定が良くなかったりするのかと思い、調べましたが、それらしい原因は見つけられませんでした。

    なにかおわかりになりましたら、お教えくださいませ。m(_ _)m

8件の投稿を表示中 - 1 - 8件目 (全8件中)