guest

動作の不具合の検証には環境情報が必要です。投稿の際は下記の情報をお書き添えください。
-------------------------------------------
WordPress のバージョン:(例 5.6)
Welcart のバージョン:(例 2.1.1)
PHP のバージョン:(例 7.4)
Welcart専用の拡張プラグインとバージョン:(例 DL Seller 3.0.8、SKU Select 1.1.4)
ご利用のテーマ:(例 WelcartBasic の自作子テーマ)
症状を確認したブラウザ:
サーバー【重要】:(会社名、サービス名)
--------------------------------------------

フォーラムへの返信

6件の投稿を表示中 - 1 - 6件目 (全6件中)
  • 投稿者
    投稿
  • guest
    参加者

    こちら再度ご質問させてください。
    今回は、前回と事象が以下のように異なりました。

    ・商品マスタ編集中に発生
    ・在庫5のやつが6個売れた上に、在庫が1個残った

    WordPressの仕様で、ページの自動保存があるかと存じます。
    在庫数を編集している時に情報が保存されてしまい、在庫情報が更新されてしまうことなどはありますでしょうか?

    その場合、自動保存を停止する方法をご教示してほしい。

    guest
    参加者

    sagawa様

    こちらでも再現しようとしましたが、出来ませんでした。

    行った手順は以下の通りです。
    1. 在庫が1の商品1を用意する
    2. ユーザーAが商品1をカートに入れる
    3. ユーザーBも商品1をカートに入れる
    4. ユーザーAで商品1を購入した(購入ボタンをクリック)
    5. ユーザーBで商品1を購入しようとしたところ、「在庫がない」というエラーが発生した(正しい挙動)

    ユーザーAはPCでの操作、ユーザーBはSafariでの操作です。

    ご検討の程よろしくお願いします。

    guest
    参加者

    ご回答ありがとうございます!

    >・商品マスタに同じ商品コード、同じSKUの商品が存在しない
    >・「売り切れ時に購入制限(在庫チェック)しない」にチェックが入っていない
    >という状況かつ、支払方法につきましては銀行振込のみということでございますね。

    はい、上記認識で間違いありません!

    >ちなみにこちらの銀行振込はオンライン収納代行の銀行振込ではなく、「銀行振込(前払い)」もしくは「銀行振込(後払い)」をWelcartの基本設定の支払方法で設定されているということでよろしかったでしょうか?

    「銀行振込(前払い)」になります。

    返信先: 売り切れ商品が購入できる #91880
    guest
    参加者

    こちらで新たに作成させていただきました。

    返信先: 売り切れ商品が購入できる #91877
    guest
    参加者

    こちらご質問させていただきます。
    銀行振り込みのみをONにしていた際に、ダブルブッキング(商品が購入できてしまった)が発生したのですが、この場合はDB側での在庫データの更新が遅れたのでしょうか?

    ◆事象
    21:40にSKUコードAの商品(在庫数1)が購入される。
    21:42にSKUコードAの商品(在庫数0)が購入される。←弾かれるはず

    お手数ですが、取り急ぎ共有させていただきます。

    ——————————————-
    WordPress のバージョン: 5.6
    Welcart のバージョン:2.1.0.2012211
    PHP のバージョン:7.2.17
    Welcart専用の拡張プラグインとバージョン:なし
    ご利用のテーマ:WelcartBasic
    症状を確認したブラウザ:83.0.4103.106 Mobile Safari
    サーバー:AWS Lightsail
    SSLの利用:常時SSL
    ——————————————-

    guest
    参加者

    途中で投稿してしまいました。
    件名の通りですが、DBエラーが発生して会員リストが取得できていない状態です。
    自分でも確認を進めて行きますが、こちらでもどなたか事象についてご存知ないかと思い投稿させていただきました。

    以下環境情報です。

    WordPress のバージョン: 5.3.2
    Welcart のバージョン:1.9.25.1912181
    PHP のバージョン:7.2.17
    Welcart専用の拡張プラグインとバージョン:特になし
    ご利用のテーマ:Welcart-child
    症状を確認したブラウザ:Chrome
    サーバー:AWS Lightsail, お名前.com
    SSLの利用:常時SSL

    雑な投稿になってしまい申し訳ありませんが、この種のエラーについてご助言いただけますと幸いです。

6件の投稿を表示中 - 1 - 6件目 (全6件中)