saruo999

動作の不具合の検証には環境情報が必要です。投稿の際は下記の情報をお書き添えください。
-------------------------------------------
WordPress のバージョン:(例 5.6)
Welcart のバージョン:(例 2.1.1)
PHP のバージョン:(例 7.4)
Welcart専用の拡張プラグインとバージョン:(例 DL Seller 3.0.8、SKU Select 1.1.4)
ご利用の親テーマとバージョン :(例 Welcart Basic 1.4.0)
ご利用の子テーマとバージョン :(例 Welcart Beldad 1.1 )
症状を確認したブラウザ:
サーバー【重要】:(会社名、サービス名)
--------------------------------------------

注意

Welcart 2.7 アップデートによる不具合の問い合わせについて

Welcart 2.7 にアップデート後にショップデータ更新を行う必要があります。
ほとんどのサイトでは問題なく完了しますが、サーバースペックなどの問題でショップデータ更新が途中で止まることがございます。
更新が完了しない方は WelRescue の不具合調査からご連絡ください。

ご連絡いただく前に、アップデート前のバックアップを利用して元の状態に戻してください。
また、以下の情報を必ずご連絡ください。
  1. ご利用のサーバー会社とプラン
  2. システム環境情報

フォーラムへの返信

15件の投稿を表示中 - 1 - 15件目 (全15件中)
  • 投稿者
    投稿
  • saruo999
    参加者

    自己解決できましたのでご報告申し上げます。
    いろいろサポート頂きありがとうございました!
    原因は、アップロードしたメディアファイルがhttp:になっていたことでした。
    これを調査したら
    設定>一般のWordpressアドレスとサイトアドレスがhttpsになっていないことが原因と判明。
    それを直したら、クレジットカード決済でドラッグ&ドロップで選択できるようになりました。

    sagawa様には何度も大変親切なコメントをいただきましてありがとうございました。
    お蔭で解決することができました。

    saruo999
    参加者

    pngの画像ファイルのリンクがhttp://となっていることを発見しました。
    このリンクはどのファイルに記述されているかを調べる方法はあるのでしょうか?

    saruo999
    参加者

    sagawa様
    なんどもすみません。

    エラーが出ている admin.phpをみますと、

    <script src='http://atwanko.com/wp-content/plugins/usc-e-shop/js/jquery/jquery.cookie.js?ver=5.8.1' id='jquery-cookie-js'></script>
    <script src='http://atwanko.com/wp-content/plugins/usc-e-shop/js/jquery/color/jscolor.js?ver=5.8.1' id='jquery-jscolor-js'></script>

    上記の2つのみがhttp://
    を使用しているようです。

    Welcart Basicをのまま何も変更せず使用しております。

    お忙しいところ、申し訳ありませんが、アドバイスいただけましたら幸いです。

    テーマの再インストール別途試してみたいと思います。

    saruo999
    参加者

    sagawa様
    何度も恐れ入ります。

    先日のコメントでは、Welcart以外のプラグインを停止しても変わらないとの事でしたが、この時も「WP Super Cache」プラグインを停止されましたでしょうか?
    また、「WP Super Cache」プラグイン停止後にキャッシュクリアをしてご確認されたということでしょうか?
    キャッシュが残っていた場合、影響が残る可能性がありますため、確認をした次第です。

    再度プラグインを停止して、WP Super Cacheも無効化して、WPの管理画面からWelcart→クレジットカード決済設定に移動、Chromeのキャッシュクリアのため、Ctrl+F5を3回ほど押下。
    で、やはりドラッグ&ドロップはできず、同じ状況でした。

    で、その時の「検証」でエラーを確認したのが添付のスクショです。
    まだadmin.phpの1行目のエラーがあるのは同じ状況でした。

    Mixed Content: The page at ‘https://atwanko.com/wp-admin/admin.php?page=usces_settlement&#8217; was loaded over HTTPS, but requested an insecure script ‘http://atwanko.com/wp-content/plugins/usc-e-shop/js/jquery/jquery.cookie.js?ver=5.8.1&#8217;. This request has been blocked; the content must be served over HTTPS.

    Mixed Contentが原因なのでしょうか?

    Attachments:
    You must be logged in to view attached files.
    saruo999
    参加者

    sagawa様
    何度もお付き合いいただきありがとうございます。
    すべてのプラグインを停止しました。WP Supr Cacheも停止しました。
    が、キャッシュクリアはしていなかったので、サイトトライしてご報告申し上げます。

    アドバイス心より感謝申し上げます。

    saruo999
    参加者

    sagawa様
    なんどもありがとうございます。
    はい。設定しております。チェックも外しています。

    saruo999
    参加者

    プラグイン wordfence では、<script src=’https://~
    となっているのですが、
    usc-e-shopのプラグインはhttp://~
    となっており
    これが原因ではないでしょうか?

    どうすば、httpsにできるのでしょうか?

    saruo999
    参加者

    クレジットカード決済設定ページのエラーの中に、http://~ を参照している部分を発見しました。
    これがMixed Contentエラーの原因のようです。

    しかし、このエラーがWordpressのどこから来ているのかがよくわからないです。

    WAFはOFFにしても変化無い様子です。(17分経過後)

    Attachments:
    You must be logged in to view attached files.
    saruo999
    参加者

    もしかして、SSLに問題があるのでしょうか?
    お名前.com RSサーバーの無料SSLというのを利用しておりますが、それが原因という可能性もあるでしょうか?

    saruo999
    参加者

    sagawa様
    >テーマフォルダ内のファイルに「http://~」と記述している箇所がないかご確認下さい。
    確認してみました。

    画像のようにwp-content – themes の下にはwelcart様関連のファイルしか配置していません。(他のテーマは削除済)

    http;//~と記述している箇所がないか、これらファイルを一つづつ確認すべきでしょうか?

    Attachments:
    You must be logged in to view attached files.
    saruo999
    参加者

    Alicia様
    RSサーバーの設定でWAFの設定をONにしておりました。
    今OFFにしてみましたので、しばらくして、Welcart Shopのクレジットカード決済選択のドラッグ&ドロップを再度トライしてみます。
    続報いたします。

    saruo999
    参加者

    sagawa様
    アドバイスありがとうございます。
    エラーメッセージでadmin.php:1 というのがその意味と言うことを理解できていませんでした。知識不足で申し訳ありません。

    で、admin.phpを確認してみましたが、httpは1行目になく、決行したの方にいかないと出てきませんでした。
    どこが悪いかご教授いただけませんでしょうか?図々しいお願いで申し訳ありません。
    ーーーーーadmin.phpよりーーーーーーーーーーーーーーーーーー
    <?php
    /**
    * WordPress Administration Bootstrap
    *
    * @package WordPress
    * @subpackage Administration
    */

    /**
    * In WordPress Administration Screens
    *
    * @since 2.3.2
    */
    if ( ! defined( ‘WP_ADMIN’ ) ) {
    define( ‘WP_ADMIN’, true );
    }

    if ( ! defined( ‘WP_NETWORK_ADMIN’ ) ) {
    define( ‘WP_NETWORK_ADMIN’, false );
    }

    if ( ! defined( ‘WP_USER_ADMIN’ ) ) {
    define( ‘WP_USER_ADMIN’, false );
    }

    if ( ! WP_NETWORK_ADMIN && ! WP_USER_ADMIN ) {
    define( ‘WP_BLOG_ADMIN’, true );
    }

    if ( isset( $_GET[‘import’] ) && ! defined( ‘WP_LOAD_IMPORTERS’ ) ) {
    define( ‘WP_LOAD_IMPORTERS’, true );
    }

    require_once dirname( __DIR__ ) . ‘/wp-load.php’;

    nocache_headers();

    if ( get_option( ‘db_upgraded’ ) ) {

    flush_rewrite_rules();
    update_option( ‘db_upgraded’, false );

    /**
    * Fires on the next page load after a successful DB upgrade.
    *
    * @since 2.8.0
    */
    do_action( ‘after_db_upgrade’ );
    ーーーー中略ーーーー

    saruo999
    参加者

    sagawa様
    コメントありがとうございます。
    ファイルに直接の「ファイル」とはどのことをおっしゃっているのでしょうか?
    要領を得なくて済みません。

    saruo999
    参加者

    ——————————————-
    WordPress のバージョン:5.8.1
    Welcart のバージョン:2.3.1
    PHP のバージョン:7.4
    Welcart専用の拡張プラグインとバージョン:(例 DL Seller 3.0.8、SKU Select 1.1.4)
    ご利用のテーマ:WelcartBasic
    症状を確認したブラウザ:Chtome, Firefox, Edge
    サーバー【重要】:お名前.com RSサーバー
    ——————————————–
    アドバイス頂き、ありがとうございました。
    ChromeのMixedContentのエラーがでていること理解しました。

    いただいたこのページに基づき、SSLの設定を見直してみましたが、エラーは改善しませんでした。
    常時SSL化はできているものと思われます。

    他にどのような対策があるか教えていただけないでしょうか?

    Attachments:
    You must be logged in to view attached files.
    saruo999
    参加者

    ——————————————-
    WordPress のバージョン:5.8.1
    Welcart のバージョン:2.3.1
    PHP のバージョン:7.4
    Welcart専用の拡張プラグインとバージョン:(例 DL Seller 3.0.8、SKU Select 1.1.4)
    ご利用のテーマ:WelcartBasic
    症状を確認したブラウザ:Chtome, Firefox, Edge
    サーバー【重要】:お名前.com RSサーバー
    ——————————————–
    ZEUSから設定完了の連絡を受け、
    https://www.welcart.com/docs/settlement/Zeus_1.0.4.pdf
    このマニュアルの通りに設定をしようと試みましたが、上記のご質問の方と全く同じで「利用できる決済モジュール」をドラッグ&ドロップで決済移動させることができない状況です。Win10のNotePC2種類、DestopPCの合計3台で試しましたがいずれも同じ状況。ブラウザもChrome,Firefox,Edgeと試しましたが同様。プラグインをWelcart以外を無効にして試しても同じでした。
    Chromeの検証機能でerrorを表示させると添付のスクショのようなエラーが出ていたので、これが原因でしょうか?とにかく、クレジットカード決済モジュールを設定する対策をご教授いただけないでしょうか?
    お忙しいところすみませんが、よろしくお願いします。

    Attachments:
    You must be logged in to view attached files.
15件の投稿を表示中 - 1 - 15件目 (全15件中)