動作の不具合の検証には環境情報が必要です。投稿の際は下記の情報をお書き添えください。
-------------------------------------------
WordPress のバージョン:(例 5.6)
Welcart のバージョン:(例 2.1.1)
PHP のバージョン:(例 7.4)
Welcart専用の拡張プラグインとバージョン:(例 DL Seller 3.0.8、SKU Select 1.1.4)
ご利用の親テーマとバージョン :(例 Welcart Basic 1.4.0)
ご利用の子テーマとバージョン :(例 Welcart Beldad 1.1 )
症状を確認したブラウザ:
サーバー【重要】:(会社名、サービス名)
--------------------------------------------

フォーラムへの返信

4件の投稿を表示中 - 1 - 4件目 (全4件中)
  • 投稿者
    投稿
  • 返信先: Welcart・WebPay関連で… #67769
    withccc
    参加者

    えーと・・・

    welcartのトピで何を言いたいのですか?

    誹謗、中傷、抗議なら直接該当サイトへどうぞ。

    オープンソースのソフトウェアは第三者に再配布しない限り、

    ソースコード公開の義務はないですね。

    該当サイトの場合は販売を目的としていますから

    「配布・販売先」にソースの公開は義務付けられています。

    ソースの公開は「配布・販売を受けた者」であって、必ずしも公衆(不特定多数)からアクセスできる場所に用意しなくても良い。

    ※一部引用

    そんなにライセンス違反だと自信があるのでしたら

    http://www.gnu.org/licenses/gpl-violation.ja.html

    で項目をチェックして抗議したらいかがですか?

    何を調べて『GPLライセンスの面では完全にアウト』と言っているのか分からないですね。

    あと何を言いたいのかもさっぱりです。

    該当サイトで依頼するのをやめて下さい的な事を言いたいのですか?

    あとEC-CUBEの「EC-CUBEライセンスについて」をちゃんと読みました?

    252,000円かかるのは(GPLライセンスに準拠しない場合)ですよ。

    しっかりとGPLライセンスとは何かを分かった上で誹謗中傷抗議を行ってください。

    返信先: Welcart・WebPay関連で… #67767
    withccc
    参加者

    久しぶりに覗いたらおかしなトピがあったので制作会社として一言。

    トピがまずいと言うかTakabiさんの考え方が理解できないのですが・・・

    >>知的財産権(GPL関連)の面でもアウトではないでしょうか?

    アウトではないと思いますよ。

    該当サイトの方がWebPayを使用できるようにして販売している・・・

    何がいけないのでしょうか?

    販売している行為が許せないのですか?

    販売ではなく個々(案件毎)に制作すれば許せるのですか?

    何が違うのでしょうか?

    この行為がライセンス違反だとしたらwordpressを扱う制作会社が殆ど違反している事になりますね。

    welcartはGPLライセンスですよね?

    GPLに準拠していれば自由に複製、改変、頒布することができるのですよ。

    「複製、改変、頒布」の意味は分かりますよね?

    他に条件と制約があるのでしたら別ですけど・・・

    該当サイトの方も馬鹿じゃないと思うのでライセンスに触れないようにはしていると思いますよ。

    何を調べて知的財産権(GPL関連)の面でもアウトだと思ったのでしょうか?

    詳しく知りたいですね。

    welcartのトピで愚痴を言うのではなく該当サイトに直接抗議したら如何ですか?

    withccc
    参加者

    経験ありますが恐らくサーバーの問題ではないでしょうか?

    xrea、coreserverなどはセーフモードで起動している為、起きる現象かと。

    https://www.welcart.com/forum/topic.php?id=1633

    welcartはセーフモード非対応なので別サーバーならWarningはでないと思います。

    withccc
    参加者

    こんばんわ。

    余計なお世話かもですが同じ症状にあった事があるので参考までにです。

    まずサーバーに問題があるかもしれません。

    coreserverはセーフモードで起動しています。

    wordpress3.4以降はセーフモードでも多少対応しているようなのですが

    プラグインはまだまだセーフモード対応が少ないです。

    そもそもwelcart自体、セーフモードは非対応?だと思います。

    サーバーを変えて試したらもしかしたら普通に機能するかもです。

    Advanced Custom Fieldsは使用した事がないですがカスタムフィールドでしたらご自身でfunctions.phpにコードを記述したらいいと思いますよ。

    参考サイト:http://wpdocs.sourceforge.jp/%E9%96%A2%E6%95%B0%E3%83%AA%E3%83%95%E3%82%A1%E3%83%AC%E3%83%B3%E3%82%B9/add_meta_box

    add_meta_boxなどgoogleで検索すると沢山情報が出ます。

    このやり方でしたらwelcartの商品追加でも表示されます。

    但し、自己責任でお願いします。

4件の投稿を表示中 - 1 - 4件目 (全4件中)