急にサイトが表示されなくなり、「WordPress がプラグイン Welcart e-Commerce でエラーを捉えました」という文面を含むメールが来ました

ホーム フォーラム バグ報告 急にサイトが表示されなくなり、「WordPress がプラグイン Welcart e-Commerce でエラーを捉えました」という文面を含むメールが来ました

このトピックには3件の返信が含まれ、2人の参加者がいます。4 週間前 nekoco さんが最後の更新を行いました。

4件の投稿を表示中 - 1 - 4件目 (全4件中)
  • 投稿者
    投稿
  • #90385

    nekoco
    参加者

    お世話になっております。
    wordpressより、下記メールが届き、サイトが表示されなくなっております。

    初めてのことで大変困っております。
    取り急ぎ、サーバーの方にも連絡しておりますが、どうぞよろしくお願い致します。

    なお、昨日までは問題なく、昨日はバージョンアップなどの更新は行っておりません。

    –下記、メール本文

    こんにちは。

    WordPress 5.2から、サイトでプラグインやテーマが致命的なエラーを発生させた場合にそれを検知してこの自動メールでお知らせする機能が追加されました。

    今回の場合、WordPress がプラグイン Welcart e-Commerce でエラーを捉えました。

    まずはじめに、ご自分のサイト (https://cookbooks.jp/shop/) を開き、目に見える問題がないか確認してください。次に、エラーが発生したページ (https://cookbooks.jp/shop/shop/wp-admin/) を開き、同様に問題がないか確認してください。

    この問題をさらに調査するにはサーバーホストに連絡してみてください。

    もしサイトが壊れていてダッシュボードに正常に接続できない場合、WordPress には特別な「リカバリーモード」があります。これによりダッシュボードに安全にログインし、さらに調査をすることができます。

    https://cookbooks.jp/shop/wp-login.php?action=enter_recovery_mode&rm_token=jg3CbTvu6ExRJojKGYzfdd&rm_key=2B5shbe3izOmQh9h5JccAx

    サイトを安全に保つため、このリンクは 1日 で有効期限が切れます。ですが、心配なく。有効期限後にこのエラーが再度発生すれば新しいリンクをお送りします。

    この問題を解決しようとする際、以下の情報を聞かれるかもしれません。
    WordPress バーション5.4.2
    現在のテーマ: Welcart Carina (バージョン 1.0.2)
    現在のプラグイン: Welcart e-Commerce (バージョン 1.9.30)
    PHP バージョン7.3.15

    エラー詳細
    ===============
    エラータイプ E_ERROR が /virtual/htdocs/shop/wp-content/plugins/usc-e-shop/includes/update_check.php ファイルの 45 行目で発生しました。 エラーメッセージ: Uncaught Error: Cannot use object of type WP_Error as array in /virtual/htdocs/shop/wp-content/plugins/usc-e-shop/includes/update_check.php:45
    Stack trace:
    #0 /virtual/htdocs/shop/wp-includes/class-wp-hook.php(287): welcart_update_check(”)
    #1 /virtual/htdocs/shop/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(NULL, Array)
    #2 /virtual/htdocs/shop/wp-includes/plugin.php(478): WP_Hook->do_action(Array)
    #3 /virtual/htdocs/shop/wp-settings.php(540): do_action(‘init’)
    #4 /virtual/htdocs/shop/wp-config.php(93): require_once(‘/virtual/htdocs…’)
    #5 /virtual/htdocs/shop/wp-load.php(37): require_once(‘/virtual/htdocs…’)
    #6 /virtual/htdocs/shop/wp-admin/admin.php(34): require_once(‘/virtual/htdocs…’)
    #7 /virtual/htdocs/shop/wp-admin/index.php(10): require_once(‘/virtual/htdocs…’)
    #8 {main}
    thrown

    #90387

    nekoco
    参加者

    お世話になっております。

    サイトの方、当方ではなにも対策をしていないのですが、
    表示されるようになりました。

    今のところ、表示に問題はない状況ですが、
    今回のエラーにつきまして、お分かりのことがございましたら、
    お知らせいただければ幸いです。

    どうぞよろしくお願い致します。

    #90393

    yskysmr
    キーマスター

    こんにちは。

    「昨日はバージョンアップなどの更新は行っておりません。」とのことですが、PHP のバージョンを変更されなかったでしょうか。最初のエラーはPHPのバージョンが低いときに発生するエラーと思われます。

    #90400

    nekoco
    参加者

    ご返信、どうもありがとうございます。

    6月25日に、phpのバージョンを7.3に上げております。
    だいぶお時間経っていますが、その影響でしょうか?

    7.4へのご対応の方、よろしくお願いいたします。

    いつもありがとうございます。

4件の投稿を表示中 - 1 - 4件目 (全4件中)

このトピックに返信するにはログインが必要です。